summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJef Roosens2022-05-17 08:13:15 +0200
committerJef Roosens2022-05-22 11:07:56 +0200
commitab11f5d758af3a9d7e902d45f0a51dd54e8cf95c (patch)
tree6bc3b3c15c590efd4f96716470d812b52ab026a7
downloadaur-ab11f5d758af3a9d7e902d45f0a51dd54e8cf95c.tar.gz
added PKGBUILD & .SRCINFO
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD47
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abb7c55db643
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cinny-desktop
+ pkgdesc = Cinny is a matrix client focusing primarily on a simple, elegant and secure interface.
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = https://github.com/cinnyapp/cinny-desktop
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = nodejs
+ makedepends = npm
+ depends = webkit2gtk
+ depends = openssl
+ depends = gtk3
+ depends = appmenu-gtk-module
+ depends = libappindicator-gtk3
+ depends = librsvg
+ depends = libvips
+ depends = sqlite
+ source = cinny-desktop::https://github.com/cinnyapp/cinny-desktop/releases/download/v2.0.3/cinny-desktop-v2.0.3.zip
+ sha256sums = c74471769c2d89904b89f6418b396b9897878708393cd0a9a9d35e082c0a7e33
+
+pkgname = cinny-desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2694ef470abf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# vim: ft=bash
+# Maintainer: Jef Roosens
+
+pkgbase='cinny-desktop'
+pkgname='cinny-desktop'
+pkgver='2.0.3'
+pkgrel='1'
+pkgdesc='Cinny is a matrix client focusing primarily on a simple, elegant and secure interface.'
+arch=('x86_64')
+
+url='https://github.com/cinnyapp/cinny-desktop'
+license=('MIT')
+
+# https://tauri.studio/v1/guides/getting-started/prerequisites#1-system-dependencies
+depends=(
+ 'webkit2gtk'
+ 'openssl'
+ 'gtk3'
+ 'appmenu-gtk-module'
+ 'libappindicator-gtk3'
+ 'librsvg'
+ 'libvips'
+ 'sqlite'
+)
+makedepends=('rust' 'nodejs' 'npm')
+
+source=("${pkgname}::https://github.com/cinnyapp/cinny-desktop/releases/download/v${pkgver}/cinny-desktop-v${pkgver}.zip")
+sha256sums=('c74471769c2d89904b89f6418b396b9897878708393cd0a9a9d35e082c0a7e33')
+
+build() {
+ cd "${pkgname}"
+
+ msg2 'Installing Node dependencies...'
+ cd 'cinny' && npm ci
+ cd .. && npm ci
+
+ msg2 'Running Tauri build...'
+ # We don't actually need the deb, but the build fails if bundles is
+ # specified as being empty.
+ npm run tauri build -- --bundles 'deb'
+}
+
+package() {
+ install -dm755 "${pkgdir}/usr/bin"
+ install -Dm755 "${pkgname}/src-tauri/target/release/cinny" "${pkgdir}/usr/bin/cinny"
+ install -Dm 644 "${pkgname}/resources/in.cinny.Cinny.desktop" "${pkgdir}/usr/share/applications/cinny.Cinny.desktop"
+}