summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukáš Jirkovský2015-06-13 17:51:04 +0200
committerLukáš Jirkovský2015-06-13 17:51:04 +0200
commitd5f5c80b6529e86ff30b5ce840b89cea03f7ae20 (patch)
treeaa2e48121ab3048a9c2b9e6198b5035e570801b0
downloadaur-d5f5c80b6529e86ff30b5ce840b89cea03f7ae20.tar.gz
ciopfs: initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a187a8dde00b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ciopfs
+ pkgdesc = Mounts a normal directory in case insensitive fashion
+ pkgver = 0.4
+ pkgrel = 2
+ url = http://www.brain-dump.org/projects/ciopfs/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = attr
+ depends = glib2
+ depends = fuse
+ source = http://www.brain-dump.org/projects/ciopfs/ciopfs-0.4.tar.gz
+ md5sums = 1798fc043034f292efd887c05fc4ea1e
+
+pkgname = ciopfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9916b8b97da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=ciopfs
+pkgver=0.4
+pkgrel=2
+pkgdesc="Mounts a normal directory in case insensitive fashion"
+arch=('i686' 'x86_64')
+url="http://www.brain-dump.org/projects/ciopfs/"
+license=('GPL2')
+depends=('attr' 'glib2' 'fuse')
+source=(http://www.brain-dump.org/projects/ciopfs/$pkgname-$pkgver.tar.gz)
+md5sums=('1798fc043034f292efd887c05fc4ea1e')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+
+ # remove sbin folder, it contains only a symlink anyway
+ rm -r $pkgdir/sbin
+}
+
+# vim:set ts=2 sw=2 et: