summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbtd13372019-09-25 17:42:29 -0300
committerbtd13372019-09-25 17:42:29 -0300
commit0cdfcba4df5fbe470c62b87ecc9474d357152621 (patch)
tree4024e6d6e10f7992044507a246add702545b2845
downloadaur-0cdfcba4df5fbe470c62b87ecc9474d357152621.tar.gz
Initial release
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cf44a35b174
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cipher-git
+ pkgdesc = Cipher is a free and open souce text encoding and decoding app specially designed for elementary os. The Cipher app can currently encode and decode between six different ciphers.
+ pkgver = r91.c060d89
+ pkgrel = 1
+ url = https://github.com/arshubham/cipher
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ depends = gtk3
+ depends = granite
+ depends = glib2
+ depends = libgee
+ provides = cipher
+ conflicts = cipher
+ source = git+https://github.com/arshubham/cipher.git
+ md5sums = SKIP
+
+pkgname = cipher-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b25c15b81fae
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aae51a180ce3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Helder Bertoldo <helder.bertoldo@gmail.com>
+# Contributor:
+
+_gitname=cipher
+_author=arshubham
+pkgname=("${_gitname}-git")
+pkgver=r91.c060d89
+pkgrel=1
+pkgdesc="Cipher is a free and open souce text encoding and decoding app specially designed for elementary os. The Cipher app can currently encode and decode between six different ciphers."
+arch=('i686' 'x86_64')
+url="https://github.com/${_author}/${_gitname}"
+license=('GPL3')
+depends=('gtk3' 'granite' 'glib2' 'libgee')
+optdepends=('')
+makedepends=('git' 'meson' 'vala')
+provides=("${_gitname}")
+conflicts=("${_gitname}")
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${_gitname}/"
+ meson . _build --prefix=/usr
+ ninja -C _build
+}
+
+package() {
+ cd "${_gitname}/"
+ DESTDIR="${pkgdir}" ninja -C _build install
+}
+