summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroliboy2021-07-07 12:50:20 +0300
committerroliboy2021-07-07 12:50:20 +0300
commit774bec10010840189854790ca1eb931d641106d6 (patch)
treeb7b3c16c845eb2992b7360ac0a5104bb93a5f650
parent88b0dd6766663e0aae91402493ddc8d3d0a938f1 (diff)
downloadaur-774bec10010840189854790ca1eb931d641106d6.tar.gz
python-cipheycore and python-cipheydists workaround
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD66
2 files changed, 65 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9aee0557154..cb37ec859888 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = ciphey
pkgdesc = Automated decryption tool
pkgver = 5.14.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Ciphey/Ciphey
arch = any
license = MIT
makedepends = python-setuptools
makedepends = python-dephell
+ makedepends = python-poetry
+ makedepends = boost
+ makedepends = swig
+ makedepends = cmake
depends = flake8
depends = python
depends = python-appdirs
depends = python-base58
depends = python-base91
- depends = python-cipheycore
- depends = python-cipheydists
depends = python-click
depends = python-mock
depends = python-pyaml
@@ -23,7 +25,11 @@ pkgbase = ciphey
depends = python-rich
depends = python-typing_inspect
provides = ciphey
- source = ciphey.tar.gz::https://codeload.github.com/Ciphey/Ciphey/tar.gz/5.14.0
+ source = ciphey.tar.gz::https://github.com/Ciphey/Ciphey/archive/refs/tags/5.14.0.tar.gz
+ source = cipheycore.tar.gz::https://github.com/Ciphey/CipheyCore/archive/refs/tags/v0.3.2.tar.gz
+ source = cipheydists.tar.gz::https://files.pythonhosted.org/packages/source/c/cipheydists/cipheydists-0.3.35.tar.gz
sha256sums = 42fd5ea5b462ab37cb2e6aed41c254e7ed44bb190fed9a3918e6bdd56d86e10f
+ sha256sums = d05b4c15077b56121e96c1b934ae2d49f14004834a9b8fbc1bdc76782cd66253
+ sha256sums = 3436fde3f57df732e1a65fb03a565a564dd9d0c8d130c2e94f8b852e6a199a88
pkgname = ciphey
diff --git a/PKGBUILD b/PKGBUILD
index bd70c6e81909..dfd22f1a4b19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,15 @@
# Maintainer: Nagy Roland <roliboy@protonmail.com>
+# NOTE: the current python-cipheycore and python-cipheydists packages in the AUR are outdated and fail to build.
+# until the situation gets resolved, these two packages will be included in this PKGBUILD.
+
pkgname=ciphey
-_pkgname=Ciphey
+
pkgver=5.14.0
-pkgrel=1
+_pkgver_cipheycore=0.3.2
+_pkgver_cipheydists=0.3.35
+
+pkgrel=2
pkgdesc='Automated decryption tool'
arch=('any')
url='https://github.com/Ciphey/Ciphey'
@@ -14,8 +20,8 @@ depends=(
'python-appdirs'
'python-base58' #aur
'python-base91' #aur
- 'python-cipheycore' #aur
- 'python-cipheydists' #aur
+# 'python-cipheycore' #aur #temporarily included in this PKGBUILD
+# 'python-cipheydists' #aur #temporarily included in this PKGBUILD
'python-click'
'python-mock'
'python-pyaml'
@@ -25,27 +31,65 @@ depends=(
'python-rich'
'python-typing_inspect'
)
-makedepends=('python-setuptools' 'python-dephell')
+makedepends=(
+ 'python-setuptools'
+ 'python-dephell'
+ 'python-poetry' #for python-cipheycore
+ 'boost' #for python-cipheycore
+ 'swig' #for python-cipheycore
+ 'cmake' #for python-cipheycore
+)
provides=('ciphey')
source=(
- "$pkgname.tar.gz::https://codeload.github.com/Ciphey/Ciphey/tar.gz/$pkgver"
+ "$pkgname.tar.gz::https://github.com/Ciphey/Ciphey/archive/refs/tags/$pkgver.tar.gz"
+ "cipheycore.tar.gz::https://github.com/Ciphey/CipheyCore/archive/refs/tags/v$_pkgver_cipheycore.tar.gz"
+ "cipheydists.tar.gz::https://files.pythonhosted.org/packages/source/c/cipheydists/cipheydists-$_pkgver_cipheydists.tar.gz"
)
sha256sums=(
'42fd5ea5b462ab37cb2e6aed41c254e7ed44bb190fed9a3918e6bdd56d86e10f'
+ 'd05b4c15077b56121e96c1b934ae2d49f14004834a9b8fbc1bdc76782cd66253'
+ '3436fde3f57df732e1a65fb03a565a564dd9d0c8d130c2e94f8b852e6a199a88'
)
prepare() {
- cd "$_pkgname-$pkgver"
+ cd "Ciphey-$pkgver"
dephell deps convert --from pyproject.toml --to setup.py
}
build() {
- cd "$_pkgname-$pkgver"
+ #cipheycore
+ cd "$srcdir/CipheyCore-$_pkgver_cipheycore"
+ mkdir build && cd build
+ cmake .. -DCIPHEY_CORE_TEST=OFF -DCMAKE_BUILD_TYPE=Release
+ cmake --build .
+ python -m poetry build
+ cd dist
+ tar xf "cipheycore-$_pkgver_cipheycore.tar.gz"
+ cd "cipheycore-$_pkgver_cipheycore"
+ python setup.py build
+
+ #cipheydists
+ cd "$srcdir/cipheydists-$_pkgver_cipheydists"
+ python setup.py build
+
+ #ciphey
+ cd "$srcdir/Ciphey-$pkgver"
python setup.py build
}
package() {
- cd "$_pkgname-$pkgver"
- python setup.py install --root=$pkgdir --optimize=1 --skip-build
- install -Dm644 license $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ #cipheycore
+ cd "$srcdir/CipheyCore-$_pkgver_cipheycore/build/dist/cipheycore-$_pkgver_cipheycore"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 "$srcdir/CipheyCore-$_pkgver_cipheycore/LICENSE" "$pkgdir/usr/share/licenses/python-cipheycore/LICENSE"
+
+ #cipheydists
+ cd "$srcdir/cipheydists-$_pkgver_cipheydists"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/python-cipheydists/LICENSE"
+
+ #ciphey
+ cd "$srcdir/Ciphey-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 license "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}