summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Emnace2018-11-29 16:35:34 +0800
committerIan Emnace2018-11-29 16:35:34 +0800
commit15837576c80c8d639e6d19e745fccf10ef05762f (patch)
treef0ffca2e564036a843aaf900a2492b3804882f6c
parent8a0c4af5418b0c39d6d9d99b7f7dc62d78b03f35 (diff)
downloadaur-15837576c80c8d639e6d19e745fccf10ef05762f.tar.gz
Fix license
The license I've been using so far was a license part of the official release tarball, which apparently covers different software (a Go-based client). The proper license is found on the upstream repo.
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89ce97852763..3b32b5586760 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,16 @@ pkgrel=1
pkgdesc="Use CircleCI from the command line"
arch=(x86_64)
url="https://github.com/CircleCI-Public/circleci-cli"
-license=(Apache)
+license=(MIT)
depends=(docker)
-source=("https://github.com/CircleCI-Public/circleci-cli/releases/download/v$pkgver/${pkgname}_${pkgver}_linux_amd64.tar.gz")
-md5sums=('9a843c4ef2d6c458e898b2f9e5609521')
+source=(
+ "https://github.com/CircleCI-Public/circleci-cli/releases/download/v$pkgver/${pkgname}_${pkgver}_linux_amd64.tar.gz"
+ "https://raw.githubusercontent.com/CircleCI-Public/circleci-cli/v$pkgver/LICENSE"
+)
+md5sums=('9a843c4ef2d6c458e898b2f9e5609521'
+ '50602d065f853eeb672e50dd157e7ad3')
package() {
- cd "${pkgname}_${pkgver}_linux_amd64"
-
- install -m 755 -D -t "$pkgdir/usr/bin" circleci
- install -m 644 -D -t "$pkgdir/usr/share/licenses/$pkgname" client/LICENSE
+ install -m 755 -D -t "$pkgdir/usr/bin" "${pkgname}_${pkgver}_linux_amd64/circleci"
+ install -m 644 -D -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}