summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosalie Tolentino2018-05-12 18:19:44 -0700
committerRosalie Tolentino2018-05-12 18:19:44 -0700
commit363ba6a1330e03159ee98f2030911e6e82919a1e (patch)
treec45b76b0f0bc83e9b002e09654b765b147f98073
parentaa28b3c2812fc5d7511fa31605ae0c6f3dea6613 (diff)
downloadaur-363ba6a1330e03159ee98f2030911e6e82919a1e.tar.gz
Updates PKDGBUILD and .SRCINFO to new circleci-cli release location
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 30 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b67cbaeaa20..060875c8b6d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = circleci-cli
- pkgdesc = A CircleCI client for building conda packages locally for example.
- pkgver = 1.0
+ pkgdesc = The circleci commands enable you to reproduce the CircleCI environment locally and run jobs as if they were running on the hosted application
+ pkgver = 0.0.4705
pkgrel = 1
- arch = i686
+ url = https://github.com/circleci/local-cli
arch = x86_64
- license = GPL3
- source = https://circle-downloads.s3.amazonaws.com/releases/build_agent_wrapper/circleci
- md5sums = 6b0d27cacf7294f3c04e4434f4dbbd8a
+ license = MIT
+ depends = docker
+ source = circleci-cli-0.0.4705.tar.gz::https://github.com/circleci/local-cli/archive/v0.0.4705-deba4df.tar.gz
+ source = https://raw.githubusercontent.com/circleci/local-cli/master/LICENSE
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = circleci-cli
diff --git a/PKGBUILD b/PKGBUILD
index d3ef32c8e487..1a91c92e262b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,29 @@
# Maintainer: Alex Peltzer ("alexpe87") <alexpe.aur@mailbox.org>
+# Co-Maintainer: rosatolen <rosatolen@gmail.com>
pkgname=circleci-cli
-pkgver=1.0
-_pkgver=${pkgver}
+pkgver=0.0.4705
pkgrel=1
-pkgdesc="A CircleCI client for building conda packages locally for example."
-arch=('i686' 'x86_64')
-url=""
-license=('GPL3')
-source=(https://circle-downloads.s3.amazonaws.com/releases/build_agent_wrapper/circleci)
-md5sums=('6b0d27cacf7294f3c04e4434f4dbbd8a')
+pkgdesc="The circleci commands enable you to reproduce the CircleCI environment locally and run jobs as if they were running on the hosted application"
+arch=('x86_64')
+url="https://github.com/circleci/local-cli"
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/circleci/local-cli/archive/v$pkgver-deba4df.tar.gz"
+'https://raw.githubusercontent.com/circleci/local-cli/master/LICENSE')
+# CircleCI publishes releases on Amazon AWS according to this documentation:
+# https://circleci.com/docs/2.0/local-cli/#installing-the-circleci-local-cli-on-macos-and-linux-distros
+# They do not provide other means of verifying their download
+md5sums=('SKIP'
+'SKIP')
+
+depends=('docker')
+
+build() {
+ mv $srcdir/local-cli-$pkgver-deba4df/circleci.sh circleci
+}
package() {
- install -Dm755 circleci $pkgdir/usr/bin/circleci
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm755 circleci $pkgdir/usr/bin/circleci
}