summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorExcitable Snowball2020-11-04 07:28:28 -0800
committerExcitable Snowball2020-11-04 07:28:28 -0800
commit066cfb381868cf90fa7042858f840884daf04bfa (patch)
treeb1ddc01ec2949d3ebb10c2b1d0d26e44512f17d3
downloadaur-066cfb381868cf90fa7042858f840884daf04bfa.tar.gz
0.0.1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c9e8b28c8c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = circuitjs1-web-bin
+ pkgdesc = Falstad circuit simulator (CircuitJS1) - webapp
+ pkgver = 20201006
+ pkgrel = 1
+ url = https://www.falstad.com/circuit/
+ arch = any
+ license = GPL2
+ conflicts = circuitjs1-web
+ source = https://www.falstad.com/circuit/offline/circuitjs1-linux64.tgz
+ md5sums = SKIP
+
+pkgname = circuitjs1-web-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..00da71a79edc
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tgz
+/*.pkg.*
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..425e69ab21b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Excitable Snowball <excitablesnowball@gmail.com>
+
+pkgname=circuitjs1-web-bin
+pkgver=20201006
+pkgrel=1
+pkgdesc="Falstad circuit simulator (CircuitJS1) - webapp"
+arch=('any')
+url="https://www.falstad.com/circuit/"
+
+# The File->About dialog in the app states that it's distributed under a GPL2
+# or later license.
+license=('GPL2')
+
+depends=()
+conflicts=(circuitjs1-web)
+source=(https://www.falstad.com/circuit/offline/circuitjs1-linux64.tgz)
+
+# The offline binary releases are unversioned.
+md5sums=(SKIP)
+
+package() {
+ cd "${srcdir}"/circuitjs1
+ mkdir -p "${pkgdir}/usr/share/webapps"
+ cp -r resources/app/war "${pkgdir}/usr/share/webapps/circuitjs1"
+}
+
+# vim:ts=2:sw=2:et: