summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2023-06-27 20:42:21 +0200
committerNarrat2023-06-27 20:42:21 +0200
commit57a30a55a778d377da0ff9d633e0437259f20246 (patch)
tree335aeef1c8f829606722b50547196451352f0a5a
parent18b7a48c07e6258ea97f743ed0f6967d7a6d12f6 (diff)
downloadaur-circus.tar.gz
circus: update to 0.18.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3de07e7096c9..6e4315fbe155 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = circus
- pkgdesc = A program that will let you run and watch multiple processes and sockets.
- pkgver = 0.14.0
+ pkgdesc = program that will let you run and watch multiple processes and sockets
+ pkgver = 0.18.0
pkgrel = 1
url = http://circus.readthedocs.org
arch = any
license = Apache
- makedepends = python-distribute
- depends = python-iowait
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-flit-core
depends = python-psutil
depends = python-pyzmq
depends = python-tornado
options = !emptydirs
- source = https://github.com/circus-tent/circus/archive/0.14.0.tar.gz
+ source = circus-0.18.0.tar.gz::https://github.com/circus-tent/circus/archive/0.18.0.tar.gz
source = circus.ini
source = circus.service
- md5sums = 066fd34445a743f5404a5873f1ca3f84
- md5sums = 6ce050f557ad88cafcc476513e0578dc
- md5sums = 94dcc7c18eb935c62699135c5d048a1a
+ b2sums = 4afa75f4e43d322b804f704a87ae31597c2a5b9514afb7a4508f58ea9d5ab8f3f0edc1799e4dd8033878521ae1d3a2b2b9e2b7d7943ff9690243f2d07c6c8045
+ b2sums = bc290e4a45cef64b2525dc4022fbddbbea7598d2a6a461386ab849f02c851f41bd5f03e29bf32064ac1efd83cf73e957b7cd3181b2bd2ad9b48bd11f11eeb59a
+ b2sums = 69d6aaa98b4fbb5ce73c093101252c9396a4c68cd77d0344b67dcccc0076aa2bb75e0202fef8d6f688f879b6c19e9616dc5c3070845ab72584ac61de55fa2426
pkgname = circus
-
diff --git a/PKGBUILD b/PKGBUILD
index 4bbbb6f0c60f..fee324c01137 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,30 @@
-# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
+
pkgname=circus
-pkgver=0.14.0
+pkgver=0.18.0
pkgrel=1
-pkgdesc="A program that will let you run and watch multiple processes and sockets."
+pkgdesc="program that will let you run and watch multiple processes and sockets"
arch=('any')
url="http://circus.readthedocs.org"
license=('Apache')
-depends=('python-iowait' 'python-psutil' 'python-pyzmq' 'python-tornado')
-makedepends=('python-distribute')
+depends=('python-psutil' 'python-pyzmq' 'python-tornado')
+makedepends=(python-build python-installer python-wheel python-flit-core)
options=(!emptydirs)
-
-source=("https://github.com/circus-tent/circus/archive/${pkgver}.tar.gz"
- "circus.ini" "circus.service")
-md5sums=('066fd34445a743f5404a5873f1ca3f84'
- '6ce050f557ad88cafcc476513e0578dc'
- '94dcc7c18eb935c62699135c5d048a1a')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/circus-tent/circus/archive/${pkgver}.tar.gz"
+ "circus.ini"
+ "circus.service")
+b2sums=('4afa75f4e43d322b804f704a87ae31597c2a5b9514afb7a4508f58ea9d5ab8f3f0edc1799e4dd8033878521ae1d3a2b2b9e2b7d7943ff9690243f2d07c6c8045'
+ 'bc290e4a45cef64b2525dc4022fbddbbea7598d2a6a461386ab849f02c851f41bd5f03e29bf32064ac1efd83cf73e957b7cd3181b2bd2ad9b48bd11f11eeb59a'
+ '69d6aaa98b4fbb5ce73c093101252c9396a4c68cd77d0344b67dcccc0076aa2bb75e0202fef8d6f688f879b6c19e9616dc5c3070845ab72584ac61de55fa2426')
build() {
- cd "$srcdir"/$pkgname-$pkgver
-
- python setup.py build
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
-
- python setup.py install --root="$pkgdir"/ --optimize=1
+ cd $pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm 644 "$srcdir"/circus.ini "$pkgdir"/etc/circus/circus.ini
install -Dm 644 "$srcdir"/circus.service "$pkgdir"/etc/systemd/system/circus.service