summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierpaolo Valerio2017-11-17 15:27:58 +0100
committerPierpaolo Valerio2017-11-17 15:27:58 +0100
commitd4faf4a5190ca7c9f8243e24d34fbc94e4e5ebe9 (patch)
tree6b2c3ac602da1bc63e55d1f81e05656bb1d7d859
downloadaur-d4faf4a5190ca7c9f8243e24d34fbc94e4e5ebe9.tar.gz
Initial submission of the KDE Frameworks 5 version of cirkuit
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD52
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81a8a915e3c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = cirkuit-kf5-git
+ pkgdesc = Small application helping you to create circuit diagrams
+ pkgver = r406.d9ff4c1
+ pkgrel = 1
+ url = git://anongit.kde.org/cirkuit.git
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = texlive-core
+ makedepends = automoc4
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ makedepends = kdesignerplugin
+ depends = poppler-qt5
+ depends = m4
+ depends = ghostscript
+ depends = texlive-pstricks
+ depends = netpbm
+ depends = knewstuff
+ depends = ktexteditor
+ depends = kdelibs4support
+ depends = hicolor-icon-theme
+ optdepends = dpic
+ provides = cirkuit
+ conflicts = cirkuit
+ options = !makeflags
+ source = git://anongit.kde.org/cirkuit.git#branch=frameworks
+ md5sums = SKIP
+
+pkgname = cirkuit-kf5-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69724b43b3ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Pierpaolo Valerio <gondsman@techgeek.co.in>
+pkgname=cirkuit-kf5-git
+pkgver=r406.d9ff4c1
+pkgrel=1
+pkgdesc="Small application helping you to create circuit diagrams"
+arch=('i686' 'x86_64')
+url="git://anongit.kde.org/cirkuit.git"
+license=('GPL')
+depends=('poppler-qt5' 'm4' 'ghostscript' 'texlive-pstricks' 'netpbm' 'knewstuff' 'ktexteditor' 'kdelibs4support' 'hicolor-icon-theme')
+optdepends=('dpic')
+makedepends=('git' 'texlive-core' 'automoc4' 'cmake' 'extra-cmake-modules' 'kdesignerplugin')
+provides=('cirkuit')
+conflicts=('cirkuit')
+source=("git://anongit.kde.org/cirkuit.git#branch=frameworks")
+md5sums=('SKIP')
+_gitname=cirkuit
+options=('!makeflags')
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "$_gitname"/src/backends
+ sed -i 's/SERVICE_TYPES cirkuit_backend.desktop/DEFAULT_SERVICE_TYPE/g' circuitmacros/CMakeLists.txt
+ sed -i 's/SERVICE_TYPES cirkuit_backend.desktop/DEFAULT_SERVICE_TYPE/g' gnuplot/CMakeLists.txt
+ sed -i 's/SERVICE_TYPES cirkuit_backend.desktop/DEFAULT_SERVICE_TYPE/g' null/CMakeLists.txt
+ sed -i 's/SERVICE_TYPES cirkuit_backend.desktop/DEFAULT_SERVICE_TYPE/g' pstricks/CMakeLists.txt
+ sed -i 's/SERVICE_TYPES cirkuit_backend.desktop/DEFAULT_SERVICE_TYPE/g' tikz/CMakeLists.txt
+ cd ..
+ sed -i 's/loadFile(filename)/loadFile(KUrl(filename))/g' mainwindow.cpp
+}
+
+build() {
+ cd "$_gitname"
+ rm -rf build
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make clean
+ make
+}
+
+package() {
+ cd "$_gitname"/build
+ make DESTDIR=${pkgdir} install
+ mv ${pkgdir}/usr/lib64/* ${pkgdir}/usr/lib
+ rmdir ${pkgdir}/usr/lib64
+ rm -rf ${pkgdir}/usr/share/apps/katepart/syntax/gnuplot.xml
+}
+