summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornnnn204302015-06-23 23:27:41 +0200
committernnnn204302015-06-23 23:27:41 +0200
commitcb05f9a0f03d29caf0b23fabffa9eac2c98f5b7b (patch)
tree40eda4fe10ab4a60538f9e4905c58409aea95d62
downloadaur-cb05f9a0f03d29caf0b23fabffa9eac2c98f5b7b.tar.gz
created git repo for AUR package of citadel
v9.01
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD36
-rw-r--r--citadel.install32
-rw-r--r--citadel.service9
4 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7a863b1c3c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = citadel
+ pkgdesc = Citadel/UX is a collaboration suite (messaging and groupware) that is descended from the Citadel family of programs which became popular in the 1980s and 1990s as a bulletin board system platform.
+ pkgver = v9.01.r0.ga845b4f
+ pkgrel = 1
+ url = http://www.citadel.org/
+ install = citadel.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = libcitadel
+ makedepends = libev
+ makedepends = c-ares
+ makedepends = curl
+ makedepends = expat
+ makedepends = libical
+ makedepends = libsieve
+ makedepends = perl-berkeleydb
+ makedepends = libtool
+ makedepends = autoconf
+ makedepends = make
+ makedepends = gcc
+ depends = libcitadel
+ depends = libev
+ depends = c-ares
+ depends = curl
+ depends = expat
+ depends = libical
+ depends = libsieve
+ depends = perl-berkeleydb
+ optdepends = openssl: SSL support
+ optdepends = shared-mime-info: filetype identification
+ source = git://git.citadel.org/appl/gitroot/citadel.git
+ source = citadel.service
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = citadel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3404b8e2a18f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: nnnn20430 <nnnn20430@mindcraft.si.eu.org>
+pkgname=citadel
+pkgver=v9.01.r0.ga845b4f
+pkgrel=1
+pkgdesc="Citadel/UX is a collaboration suite (messaging and groupware) that is descended from the Citadel family of programs which became popular in the 1980s and 1990s as a bulletin board system platform."
+arch=('i686' 'x86_64')
+url="http://www.citadel.org/"
+license=('GPL')
+depends=('libcitadel' 'libev' 'c-ares' 'curl' 'expat' 'libical' 'libsieve' 'perl-berkeleydb')
+makedepends=('git' 'libcitadel' 'libev' 'c-ares' 'curl' 'expat' 'libical' 'libsieve' 'perl-berkeleydb' 'libtool' 'autoconf' 'make' 'gcc')
+optdepends=('openssl: SSL support' 'shared-mime-info: filetype identification')
+conflicts=()
+changelog=""
+source=("git://git.citadel.org/appl/gitroot/citadel.git" "citadel.service")
+install="citadel.install"
+md5sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/citadel"
+ git checkout v9.01
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/citadel/citadel"
+ ./bootstrap
+ ./configure --prefix=/usr/local/citadel
+ make
+}
+
+package() {
+ cd "$srcdir/citadel/citadel"
+ make DESTDIR="$pkgdir" install
+ mkdir -p "$pkgdir/usr/lib/systemd/system"
+ cp "$startdir/citadel.service" "$pkgdir/usr/lib/systemd/system/citadel.service"
+}
diff --git a/citadel.install b/citadel.install
new file mode 100644
index 000000000000..d17c394572a4
--- /dev/null
+++ b/citadel.install
@@ -0,0 +1,32 @@
+## arg 1: the new package version
+pre_install() {
+ :;
+}
+
+## arg 1: the new package version
+post_install() {
+ echo "run 'systemctl start citadel'"
+ echo "then run '/usr/local/citadel/setup' to configure citadel"
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ :;
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ :;
+}
+
+## arg 1: the old package version
+pre_remove() {
+ :;
+}
+
+## arg 1: the old package version
+post_remove() {
+ :;
+}
diff --git a/citadel.service b/citadel.service
new file mode 100644
index 000000000000..77f6013ab448
--- /dev/null
+++ b/citadel.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Citadel/UX Groupware
+
+[Service]
+ExecStart=/usr/local/citadel/citserver -d
+Type=forking
+
+[Install]
+WantedBy=multi-user.target