summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-05-05 23:32:39 +0300
committerIgor Dyatlov2022-05-05 23:32:39 +0300
commit082adb7e21109ec8553f9129bc949527944fffe7 (patch)
tree9b7cd6f1c05e512b71bddd2d341d0ed80b8aa693
downloadaur-082adb7e21109ec8553f9129bc949527944fffe7.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e58cd057368f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = citations
+ pkgdesc = Manage your bibliographies using the BibTeX format
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://gitlab.gnome.org/msandova/citations
+ arch = x86_64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = meson
+ makedepends = rust
+ depends = glib2
+ depends = libadwaita-git
+ source = https://gitlab.gnome.org/msandova/citations/-/archive/0.1.0/citations-0.1.0.tar
+ b2sums = e77fd43c464fc017bf86089e8d8c3c59450961c12a3dd82680277560b8dc85115ece6363ce8768b26d9eaa9e6cc5bbcf79bae8672a79baeb9f52643f31432965
+
+pkgname = citations
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e96657af65cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=citations
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Manage your bibliographies using the BibTeX format"
+arch=('x86_64')
+url="https://gitlab.gnome.org/msandova/citations"
+license=('GPL3')
+depends=('glib2' 'libadwaita-git')
+makedepends=('meson' 'rust')
+checkdepends=('appstream-glib')
+source=($url/-/archive/$pkgver/$pkgname-$pkgver.tar)
+b2sums=('e77fd43c464fc017bf86089e8d8c3c59450961c12a3dd82680277560b8dc85115ece6363ce8768b26d9eaa9e6cc5bbcf79bae8672a79baeb9f52643f31432965')
+
+build() {
+ arch-meson "$pkgname-$pkgver" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}