summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2023-02-08 19:54:22 +0300
committerIgor Dyatlov2023-02-08 19:54:22 +0300
commitc4c139f9cd1099e751e1b9ad20ba0bd5f08a17b9 (patch)
treee1ad7b15b66f3766769a84b89208b3848d74e071
parentbdd70103294ebcb5db043fc8728b2916f6345b7e (diff)
downloadaur-c4c139f9cd1099e751e1b9ad20ba0bd5f08a17b9.tar.gz
Update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1eeae84e200d..ff88ff0f1365 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = citations
pkgdesc = Manage your bibliographies using the BibTeX format
- pkgver = 0.5.0
+ pkgver = 0.5.1
pkgrel = 1
url = https://gitlab.gnome.org/World/citations
arch = x86_64
@@ -9,10 +9,10 @@ pkgbase = citations
checkdepends = appstream-glib
makedepends = meson
makedepends = cargo
- depends = libadwaita-git
- depends = poppler
+ depends = libadwaita
+ depends = poppler-glib
depends = gtksourceview5
- source = https://gitlab.gnome.org/World/citations/-/archive/0.5.0/citations-0.5.0.tar.gz
- b2sums = 6f18599b4ef53d079201d16496de282d59ac8e8980298f7372be658c96838c1125b938db600032e1c6573d1d7e376c4b071948326b912a63e75357a2594755b3
+ source = https://gitlab.gnome.org/World/citations/-/archive/0.5.1/citations-0.5.1.tar.gz
+ b2sums = 9510bc2ae8c94193728d635824f607f701410bbbb47ad96b67440886f355656ffe7cbad098fd444be639b90d0d2d309578e3f805350396972a70890d9ea2fdd5
pkgname = citations
diff --git a/PKGBUILD b/PKGBUILD
index 5ddfaf1ab6b0..8cb57f5a3630 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=citations
-pkgver=0.5.0
+pkgver=0.5.1
pkgrel=1
pkgdesc="Manage your bibliographies using the BibTeX format"
arch=('x86_64' 'aarch64')
url="https://gitlab.gnome.org/World/citations"
license=('GPL3')
-depends=('libadwaita-git' 'poppler' 'gtksourceview5')
+depends=('libadwaita' 'poppler-glib' 'gtksourceview5')
makedepends=('meson' 'cargo')
checkdepends=('appstream-glib')
source=($url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz)
-b2sums=('6f18599b4ef53d079201d16496de282d59ac8e8980298f7372be658c96838c1125b938db600032e1c6573d1d7e376c4b071948326b912a63e75357a2594755b3')
+b2sums=('9510bc2ae8c94193728d635824f607f701410bbbb47ad96b67440886f355656ffe7cbad098fd444be639b90d0d2d309578e3f805350396972a70890d9ea2fdd5')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
build() {
+ export RUSTUP_TOOLCHAIN=stable
arch-meson "$pkgname-$pkgver" build
meson compile -C build
}
check() {
- meson test -C build || :
+ meson test -C build --print-errorlogs || :
}
package() {