summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMendel Greenberg2021-08-09 14:24:03 -0400
committerMendel Greenberg2021-08-09 14:24:03 -0400
commitf5fd6d2c3390f7980b5f5b64595b00466b5b044c (patch)
tree265cac250c8ab7e1d6f79c15bddfe370fb95383d
parent18680bb88978294d12caf2a5e0f43c2f868ef8cd (diff)
downloadaur-f5fd6d2c3390f7980b5f5b64595b00466b5b044c.tar.gz
further fixes
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD5
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90a11d8ce80d..8d28510bafbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,14 +5,6 @@ pkgbase = citra-canary-bin
url = https://citra-emu.org
arch = x86_64
license = GPL2
- conflicts = citra-git
- conflicts = citra-qt-git
- conflicts = citra-nightly-bin
- conflicts = citra-qt-nightly-bin
- conflicts = citra-bin
- conflicts = citra-qt
- conflicts = citra-canary-bin
- conflicts = citra-qt-canary-bin
source = https://github.com/citra-emu/citra-canary/releases/download/canary-1984/citra-linux-20210809-1bc889a.tar.xz
source = https://raw.githubusercontent.com/citra-emu/citra/master/dist/citra.desktop
sha256sums = 802e6ad1a1f6ab81b508e3608eae03ceaee9380fe3bb9004b3adbfc856358639
@@ -22,7 +14,9 @@ pkgname = citra-canary-bin
depends = ffmpeg-compat-57
depends = libsndio-61-compat
depends = sdl2
- provides = citra
+ conflicts = citra-git
+ conflicts = citra-nightly-bin
+ conflicts = citra-bin
pkgname = citra-qt-canary-bin
depends = ffmpeg-compat-57
@@ -32,4 +26,6 @@ pkgname = citra-qt-canary-bin
depends = desktop-file-utils
optdepends = libxkbcommon-x11: for X11 support
optdepends = qt5-wayland: for Wayland support
- provides = citra-qt
+ conflicts = citra-qt-git
+ conflicts = citra-qt-nightly-bin
+ conflicts = citra-qt
diff --git a/PKGBUILD b/PKGBUILD
index 9c99b29341b0..8507ed5896f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,6 @@ pkgname=('citra-canary-bin' 'citra-qt-canary-bin')
pkgrel=1
pkgver=1984_20210809_1bc889a
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
-conflicts=('citra-git' 'citra-qt-git' 'citra-nightly-bin' 'citra-qt-nightly-bin' 'citra-bin' 'citra-qt' 'citra-canary-bin' 'citra-qt-canary-bin')
license=('GPL2')
arch=('x86_64')
url="https://citra-emu.org"
@@ -21,7 +20,7 @@ sha256sums=('802e6ad1a1f6ab81b508e3608eae03ceaee9380fe3bb9004b3adbfc856358639'
package_citra-canary-bin() {
depends=('ffmpeg-compat-57' 'libsndio-61-compat' 'sdl2')
- provides=('citra')
+ conflicts=('citra-git' 'citra-nightly-bin' 'citra-bin')
cd "${srcdir}/citra-linux-${_ref}"
@@ -33,7 +32,7 @@ package_citra-qt-canary-bin() {
depends=('ffmpeg-compat-57' 'qt5-multimedia' 'libsndio-61-compat' 'sdl2' 'desktop-file-utils')
optdepends=('libxkbcommon-x11: for X11 support'
'qt5-wayland: for Wayland support')
- provides=('citra-qt')
+ conflicts=('citra-qt-git' 'citra-qt-nightly-bin' 'citra-qt')
cd "${srcdir}/citra-linux-${_ref}"