summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-08-12 13:48:36 -0500
committerHurricanePootis2023-08-12 13:48:36 -0500
commit8feceb5fa5b9b6b32ddcf1b04aa9b146bd715ecf (patch)
tree56406391ac21ba43350801e06eea1613b05d7d29
parent120d9acedf1fb142c40c7a0c160951e89a7e9336 (diff)
downloadaur-8feceb5fa5b9b6b32ddcf1b04aa9b146bd715ecf.tar.gz
Switch to clang and add vulkan-headers to makedepends
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD12
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1015bfbb5efc..1554221c83a9 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = citra-canary-git
pkgdesc = An experimental open-source Nintendo 3DS emulator/debugger
- pkgver = 2545.r0.g1872ada
+ pkgver = 2584.r0.gf84df94
pkgrel = 1
url = https://github.com/citra-emu/citra-canary
arch = i686
@@ -14,8 +14,9 @@ pkgbase = citra-canary-git
makedepends = llvm
makedepends = boost
makedepends = qt6-tools
- makedepends = gcc
+ makedepends = clang
makedepends = glslang
+ makedepends = vulkan-headers
depends = sdl2
depends = mbedtls
depends = speexdsp
@@ -39,7 +40,7 @@ pkgbase = citra-canary-git
conflicts = citra-canary
conflicts = citra-git
conflicts = citra-qt-git
- options = lto
+ options = !lto
options = strip
options = !debug
source = citra::git+https://github.com/citra-emu/citra-canary.git
diff --git a/PKGBUILD b/PKGBUILD
index e1c42b121300..bdd51e9d2a88 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=citra
pkgname=$_pkgname-canary-git
-pkgver=2545.r0.g1872ada
+pkgver=2584.r0.gf84df94
pkgrel=1
pkgdesc='An experimental open-source Nintendo 3DS emulator/debugger'
arch=('i686' 'x86_64')
@@ -11,9 +11,11 @@ url='https://github.com/citra-emu/citra-canary'
_debug=false # Set _debug to true to enable building a build that can be debugged with gdb
if [ $_debug = "false" ]
then
- options=("lto" "strip" "!debug")
+ options=("!lto" "strip" "!debug")
_cmake_build_type=Release
_enable_lto=true
+ CFLAGS+=" -flto=thin"
+ CXXFLAGS+=" -flto=thin"
else
options=("!lto" "!strip" "debug")
_cmake_build_type=Debug
@@ -23,7 +25,7 @@ provides=("citra" "citra-qt" "citra-canary" "citra-git" "citra-qt-git")
conflicts=("citra" "citra-qt" "citra-canary" "citra-git" "citra-qt-git")
license=('GPL2')
depends=('sdl2' 'mbedtls' 'speexdsp' 'qt6-multimedia' 'ffmpeg' 'boost-libs' 'libfdk-aac' 'libusb' 'openssl' 'glibc' 'gcc-libs' 'sndio' 'libbacktrace-git')
-makedepends=('git' 'cmake' 'python' 'doxygen' 'rapidjson' 'llvm' 'boost' 'qt6-tools' 'gcc' 'glslang')
+makedepends=('git' 'cmake' 'python' 'doxygen' 'rapidjson' 'llvm' 'boost' 'qt6-tools' 'clang' 'glslang' 'vulkan-headers')
source=("$_pkgname::git+https://github.com/citra-emu/citra-canary.git"
"boost::git+https://github.com/citra-emu/ext-boost.git"
"nihstro::git+https://github.com/neobrain/nihstro.git"
@@ -144,8 +146,8 @@ build() {
-DUSE_DISCORD_PRESENCE=ON \
-DUSE_SYSTEM_BOOST=OFF \
-DUSE_SYSTEM_SDL2=ON \
- -DCMAKE_C_COMPILER=gcc \
- -DCMAKE_CXX_COMPILER=g++ \
+ -DCMAKE_C_COMPILER=clang \
+ -DCMAKE_CXX_COMPILER=clang++ \
-DCMAKE_C_FLAGS="$CFLAGS" \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-Wno-dev