summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Schumacher2019-12-20 17:28:48 +0100
committerTim Schumacher2019-12-20 17:28:48 +0100
commit2a08dbf30e007628184995c16a8a6bdf74cee104 (patch)
treeba5bffb22179569585593063f68d6eaaf4823b8e
parent61f39e5985cd7742bbeeed03877bacc3531af1fe (diff)
downloadaur-2a08dbf30e007628184995c16a8a6bdf74cee104.tar.gz
Enable the ffmpeg audio decoder
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e69343fce15d..b68f76b00ff4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = citra-git
pkgdesc = An experimental open-source Nintendo 3DS emulator/debugger
- pkgver = r7941.3e9c2e77d
- pkgrel = 1
+ pkgver = r8192.020cd56ad
+ pkgrel = 2
url = https://github.com/citra-emu/citra/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 59abc24708e6..bc5ce89bce49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r7941.3e9c2e77d
-pkgrel=1
+pkgver=r8192.020cd56ad
+pkgrel=2
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
url="https://github.com/citra-emu/citra/"
@@ -34,6 +34,9 @@ build() {
# Fix for an issue some users are facing when compiling with GCC
CXXFLAGS+=" -DFMT_USE_USER_DEFINED_LITERALS=0"
+ # Fix for missing AAC decoder for Pokemon X/Y
+ CXXFLAGS+=" -DENABLE_FFMPEG_AUDIO_DECODER=ON"
+
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \