summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2016-09-20 11:57:31 +0900
committerEmmanuel Gil Peyrot2016-09-20 11:57:31 +0900
commit4a0a24e4aa19307e3df4d109ddbdeb82502140bc (patch)
tree64f03efa8e5ea4f66624d1af09c29b7e4a0cc3b3
parentc6f19a576beb537c354a80c62d648b7da2cbbd2e (diff)
downloadaur-4a0a24e4aa19307e3df4d109ddbdeb82502140bc.tar.gz
Add newer dependencies, and enable tests.
-rw-r--r--PKGBUILD22
1 files changed, 19 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a0f705fa442..73344222c771 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r3900.5cd3701
+pkgver=r3918.8bf09b5
pkgrel=1
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
@@ -15,8 +15,12 @@ source=("$_pkgbase::git+https://github.com/citra-emu/citra"
'git+https://github.com/citra-emu/ext-boost'
'git+https://github.com/svn2github/inih'
'git+https://github.com/neobrain/nihstro'
- 'git+https://github.com/citra-emu/ext-soundtouch')
-md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+ 'git+https://github.com/citra-emu/ext-soundtouch'
+ 'git+https://github.com/philsquared/Catch'
+ 'git+https://github.com/MerryMage/dynarmic'
+ 'git+https://github.com/fmtlib/fmt'
+ 'git+https://github.com/herumi/xbyak')
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/$_pkgbase"
@@ -32,6 +36,13 @@ prepare() {
git config submodule.inih.url "$srcdir/inih"
git config submodule.nihstro.url "$srcdir/nihstro"
git config submodule.soundtouch.url "$srcdir/ext-soundtouch"
+ git config submodule.catch.url "$srcdir/Catch"
+ git config submodule.dynarmic.url "$srcdir/dynarmic"
+ git submodule update
+
+ cd externals/dynarmic
+ git config submodule.externals/fmt.url "$srcdir/fmt"
+ git config submodule.externals/xbyak.url "$srcdir/xbyak"
git submodule update
}
@@ -41,6 +52,11 @@ build() {
make
}
+check() {
+ cd "$srcdir/$_pkgbase/build"
+ make test
+}
+
package_citra-git() {
depends=('sdl2' 'libpng')