summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Schumacher2018-07-11 14:52:06 +0200
committerTim Schumacher2018-07-11 14:52:06 +0200
commit7cfac2029a325adc275bbf945e99f471df1c1323 (patch)
treeef95c730ac68d0c3fec79c287df53ecf4ed3ce7e
parentf407430010ff69917f9154a002e861f63f423d52 (diff)
downloadaur-7cfac2029a325adc275bbf945e99f471df1c1323.tar.gz
Fix the remaining package issues
- Added qt5-multimedia as build-dependency - Changed the "git submodule update" calls to "git submodule update --init --recursive"
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28a1335c763c..7648f6cde15e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Dec 6 09:47:40 UTC 2017
pkgbase = citra-git
pkgdesc = An experimental open-source Nintendo 3DS emulator/debugger
- pkgver = r5401.fcf0d104
+ pkgver = r6392.edcea9094
pkgrel = 1
url = https://github.com/citra-emu/citra/
arch = i686
@@ -14,6 +12,7 @@ pkgbase = citra-git
makedepends = qt5-base
makedepends = shared-mime-info
makedepends = desktop-file-utils
+ makedepends = qt5-multimedia
source = citra::git+https://github.com/citra-emu/citra
source = git+https://github.com/citra-emu/ext-boost
source = git+https://github.com/neobrain/nihstro
diff --git a/PKGBUILD b/PKGBUILD
index 9ef9b6fbb218..dd6e31d7b45b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r5442.e784434a
+pkgver=r6392.edcea9094
pkgrel=1
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
url="https://github.com/citra-emu/citra/"
license=('GPL2')
-makedepends=('git' 'cmake' 'sdl2' 'qt5-base' 'shared-mime-info' 'desktop-file-utils')
+makedepends=('git' 'cmake' 'sdl2' 'qt5-base' 'shared-mime-info' 'desktop-file-utils' 'qt5-multimedia')
source=("$_pkgbase::git+https://github.com/citra-emu/citra"
'git+https://github.com/citra-emu/ext-boost'
'git+https://github.com/neobrain/nihstro'
@@ -57,12 +57,12 @@ prepare() {
git config submodule.enet.url "$srcdir/enet"
git config submodule.cpr.url "$srcdir/cpr"
git config submodule.inih.url "$srcdir/inih"
- git submodule update
+ git submodule update --init --recursive
cd externals/dynarmic
git config submodule.externals/fmt.url "$srcdir/fmt"
git config submodule.externals/xbyak.url "$srcdir/xbyak"
- git submodule update
+ git submodule update --init --recursive
}
build() {