summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2018-03-21 01:46:42 -0400
committerBrendan Szymanski2018-03-21 01:46:42 -0400
commit6ae5178c693d5e11d178e404fed1f3f00b69e395 (patch)
treea3c6629b34629b4ca4659ace3167c3518b73d1ec
downloadaur-6ae5178c693d5e11d178e404fed1f3f00b69e395.tar.gz
Initial AUR upload
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD82
2 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d48a5542eff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = citra-qt-canary-git
+ pkgdesc = An experimental open-source Nintendo 3DS emulator/debugger written in C++
+ pkgver = r5876.0a2fbb53
+ pkgrel = 1
+ url = https://github.com/citra-emu/citra-canary/tree/master
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = sdl2
+ makedepends = qt5-base
+ makedepends = cmake
+ depends = shared-mime-info
+ depends = desktop-file-utils
+ optdepends = libxkbcommon-x11: for X11 support
+ optdepends = qt5-wayland: for Wayland support
+ source = citra::git+https://github.com/citra-emu/citra-canary#branch=master
+ source = git+https://github.com/citra-emu/ext-boost
+ source = git+https://github.com/neobrain/nihstro
+ source = git+https://github.com/citra-emu/ext-soundtouch
+ source = git+https://github.com/philsquared/Catch
+ source = git+https://github.com/MerryMage/dynarmic
+ source = git+https://github.com/herumi/xbyak
+ source = git+https://github.com/weidai11/cryptopp
+ source = git+https://github.com/fmtlib/fmt
+ source = git+https://github.com/lsalzman/enet
+ source = git+https://github.com/benhoyt/inih
+ source = git+https://github.com/j-selby/libressl-portable
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = citra-qt-canary-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28552dac3d8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,82 @@
+# Maintainer: Brendan Szymanski <brendan.szymanski1@gmail.com>
+
+_pkgname=citra
+pkgname=$_pkgname-qt-canary-git
+pkgver=r5876.0a2fbb53
+pkgrel=1
+pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger written in C++"
+arch=('i686' 'x86_64')
+url="https://github.com/citra-emu/citra-canary/tree/master"
+license=('GPL2')
+depends=('shared-mime-info' 'desktop-file-utils')
+makedepends=('git' 'sdl2' 'qt5-base' 'cmake')
+optdepends=('libxkbcommon-x11: for X11 support'
+ 'qt5-wayland: for Wayland support')
+source=("$_pkgname::git+https://github.com/citra-emu/citra-canary#branch=master"
+ 'git+https://github.com/citra-emu/ext-boost'
+ 'git+https://github.com/neobrain/nihstro'
+ 'git+https://github.com/citra-emu/ext-soundtouch'
+ 'git+https://github.com/philsquared/Catch'
+ 'git+https://github.com/MerryMage/dynarmic'
+ 'git+https://github.com/herumi/xbyak'
+ 'git+https://github.com/weidai11/cryptopp'
+ 'git+https://github.com/fmtlib/fmt'
+ 'git+https://github.com/lsalzman/enet'
+ 'git+https://github.com/benhoyt/inih'
+ 'git+https://github.com/j-selby/libressl-portable')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p build
+
+ git submodule init
+ git config submodule.boost.url "$srcdir/ext-boost"
+ git config submodule.nihstro.url "$srcdir/nihstro"
+ git config submodule.soundtouch.url "$srcdir/ext-soundtouch"
+ git config submodule.catch.url "$srcdir/Catch"
+ git config submodule.dynarmic.url "$srcdir/dynarmic"
+ git config submodule.xbyak.url "$srcdir/xbyak"
+ git config submodule.cryptopp.url "$srcdir/cryptopp"
+ git config submodule.fmt.url "$srcdir/fmt"
+ git config submodule.enet.url "$srcdir/enet"
+ git config submodule.inih.url "$srcdir/inih"
+ git config submodule.libressl.url "$srcdir/libressl-portable"
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/$_pkgname/build"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_SYSTEM_CURL=1
+ make
+}
+
+check() {
+ cd "$srcdir/$_pkgname/build"
+ make test
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make DESTDIR="$pkgdir/" install
+ rm "$pkgdir/usr/bin/$_pkgname"
+}