summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Kuesters2017-11-20 11:07:21 -0200
committerRichard Kuesters2017-11-20 11:07:21 -0200
commit8cee250a0cf07f23d03bfe3b5b17d9e1143bf353 (patch)
tree8d2607fe2de04042d697603a99ed6c6e75be5f52
downloadaur-8cee250a0cf07f23d03bfe3b5b17d9e1143bf353.tar.gz
first version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
-rw-r--r--citus-git.install9
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7b7423a3224
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = citus-git
+ pkgdesc = Scalable PostgreSQL for multi-tenant and real-time workloads
+ pkgver = 6.1.0.rc2.r663.g666e3727
+ pkgrel = 1
+ url = https://github.com/citusdata/citus
+ arch = any
+ license = AGPL-3.0
+ makedepends = postgresql-libs git
+ depends = postgresql
+ source = git+https://github.com/citusdata/citus
+ sha1sums = SKIP
+
+pkgname = citus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..906bbfeb1abc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: vltr <rkuesters@gmail.com>
+pkgname=citus-git
+pkgver=6.1.0.rc2.r670.g785d94e8
+pkgrel=1
+pkgdesc="Scalable PostgreSQL for multi-tenant and real-time workloads"
+url="https://github.com/citusdata/citus"
+arch=('any')
+license=('AGPL-3.0')
+depends=('postgresql')
+makedepends=('postgresql-libs' 'git')
+install="${pkgname}.install"
+source=(git+https://github.com/citusdata/citus)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd citus
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd citus
+ ./configure
+ make
+}
+
+package() {
+ cd citus
+ make DESTDIR=${pkgdir} install
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/citus-git.install b/citus-git.install
new file mode 100644
index 000000000000..b2da22124c8b
--- /dev/null
+++ b/citus-git.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "To use citus, edit your /var/lib/postgres/data/postgresql.conf
+to uncoment 'shared_preload_libraries' and add required library:
+ shared_preload_libraries = 'citus'
+If you already have any other shared library preloaded in your
+postgres, add it as the first lib (as recommended by citus):
+ shared_preload_libraries = 'citus, otherext'
+Then restart postgres."
+}