summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2018-02-07 23:14:44 +0100
committerPhilip Goto2018-02-07 23:14:44 +0100
commit85f5685415c81e60b1807cb2c1a80019744e8be1 (patch)
tree5ce28f3e0e4dea6e001f69fa005c39284d682689
downloadaur-85f5685415c81e60b1807cb2c1a80019744e8be1.tar.gz
Initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6727adf65d66
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = civic
+ pkgdesc = CiviC Toolchain used in the UvA Compiler Construction course
+ pkgver = 1.0.0
+ pkgrel = 1
+ arch = x86_64
+ license = custom:UvA Proprietary
+ source = toolchain-linux-x64-static.tgz::https://:@blackboard.uva.nl/bbcswebdav/pid-6926466-dt-content-rid-10679020_1/xid-10679020_1
+ md5sums = a42d166e73b8454e839c1c7d7fcd8036
+
+pkgname = civic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f1474fdb8db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+# BlackBoard username and password
+_username=
+_password=
+
+pkgname=civic
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="CiviC Toolchain used in the UvA Compiler Construction course"
+arch=('x86_64')
+license=('custom:UvA Proprietary')
+source=("toolchain-linux-x64-static.tgz::https://${_username}:${_password}@blackboard.uva.nl/bbcswebdav/pid-6926466-dt-content-rid-10679020_1/xid-10679020_1")
+md5sums=('a42d166e73b8454e839c1c7d7fcd8036')
+
+package() {
+ cd "${srcdir}/bin/"
+ install -dm 755 "${pkgdir}/usr/bin"
+ install -m 755 "civas" "${pkgdir}/usr/bin"
+ install -m 755 "civcc" "${pkgdir}/usr/bin"
+ install -m 755 "civvm" "${pkgdir}/usr/bin"
+ install -m 755 "civrun" "${pkgdir}/usr/bin"
+
+ install -dm 755 "${pkgdir}/usr/include"
+ install -m 644 "civic.h" "${pkgdir}/usr/include"
+}