summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2019-08-09 00:13:53 -0400
committerKevin MacMartin2019-08-09 00:13:53 -0400
commit5fcaf78bb30a8814d29373b59f41810ce9235c88 (patch)
tree4c33f2e53e9c5e726061d31125a4d1d3aabfa3b0
parent5d477793005302209f4b75d53f3a3ee122e7062e (diff)
downloadaur-5fcaf78bb30a8814d29373b59f41810ce9235c88.tar.gz
Add llvm as a dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07b93e82f9af..4196d47d8588 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cjdns-git
pkgdesc = A routing engine designed for security, scalability, speed and ease of use
pkgver = 20.3.r13.g2dfc2a59
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cjdelisle/cjdns
arch = i686
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = cjdns-git
makedepends = nodejs
makedepends = python2
makedepends = binutils
+ makedepends = llvm
depends = bash
optdepends = cjdnsify: allows you to run some programs bound to your cjdns address
optdepends = cjdns-git-sysvinit: support for sysvinit (rc.d)
diff --git a/PKGBUILD b/PKGBUILD
index dd3102fe6777..b84b7aeafb3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,14 @@
_pkgname=cjdns
pkgname=$_pkgname-git
pkgver=20.3.r13.g2dfc2a59
-pkgrel=1
+pkgrel=2
pkgdesc='A routing engine designed for security, scalability, speed and ease of use'
url='https://github.com/cjdelisle/cjdns'
license=('GPL3')
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
options=('!distcc' '!strip' '!buildflags')
depends=('bash')
-makedepends=('git' 'nodejs' 'python2' 'binutils')
+makedepends=('git' 'nodejs' 'python2' 'binutils' 'llvm')
optdepends=(
'cjdnsify: allows you to run some programs bound to your cjdns address'