summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-12-01 20:01:02 -0500
committerKevin MacMartin2015-12-01 20:01:02 -0500
commit65136d4c4a4f815c86662ff363abc8edd5acca30 (patch)
tree43e52583dd5413e7712a83829182092ffdfc8191
parentc4dcdfb0f9fafeadf556cc7deb725fdee95523a3 (diff)
downloadaur-65136d4c4a4f815c86662ff363abc8edd5acca30.tar.gz
Add patch to fix build on i686
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--seccomp-bind-getsockaddr.patch29
3 files changed, 40 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3734ac1060d0..35bb3b2a52d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cjdns-git
pkgdesc = A routing engine designed for security, scalability, speed and ease of use
pkgver = 17.1.r72.g68693cc
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cjdelisle/cjdns
arch = i686
arch = x86_64
@@ -21,7 +21,9 @@ pkgbase = cjdns-git
options = !strip
options = !buildflags
source = git+https://github.com/cjdelisle/cjdns#branch=crashey
+ source = seccomp-bind-getsockaddr.patch
sha512sums = SKIP
+ sha512sums = 547db6c204c029375fa435414dc3a15d4df3cb6d73a65ad7c9476454dc1cc5ded6cf5cfca75ccd580ed98b2ca4508127572eb4bd2d4c7847015c94c014bd18a4
pkgname = cjdns-git
diff --git a/PKGBUILD b/PKGBUILD
index 3edfd6fd020c..795a5800845b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=cjdns
pkgname=$_pkgname-git
pkgver=17.1.r72.g68693cc
-pkgrel=1
+pkgrel=2
pkgdesc='A routing engine designed for security, scalability, speed and ease of use'
url='https://github.com/cjdelisle/cjdns'
license=('GPL3')
@@ -20,14 +20,19 @@ optdepends=(
)
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+$url#branch=crashey")
-sha512sums=('SKIP')
+source=("git+$url#branch=crashey" 'seccomp-bind-getsockaddr.patch')
+sha512sums=('SKIP' '547db6c204c029375fa435414dc3a15d4df3cb6d73a65ad7c9476454dc1cc5ded6cf5cfca75ccd580ed98b2ca4508127572eb4bd2d4c7847015c94c014bd18a4')
pkgver() {
cd $_pkgname
git describe --tags | sed 's|^[^-]*-v||;s|-|.r|;s|-|.|g'
}
+prepare() {
+ cd $_pkgname
+ patch -p1 < ../seccomp-bind-getsockaddr.patch
+}
+
build() {
cd $_pkgname
bash 'do'
diff --git a/seccomp-bind-getsockaddr.patch b/seccomp-bind-getsockaddr.patch
new file mode 100644
index 000000000000..5327bc000ddc
--- /dev/null
+++ b/seccomp-bind-getsockaddr.patch
@@ -0,0 +1,29 @@
+From 87d78ec488bfbbab3683b64c1c58b53b50c08803 Mon Sep 17 00:00:00 2001
+From: Kubuxu <kubuxu@gmail.com>
+Date: Tue, 1 Dec 2015 17:14:27 +0100
+Subject: [PATCH] SECCOMP: bind and getsockaddr do not exist Introduced in
+ 3712d583b8ac7b940521d96107cb06
+
+---
+ util/Seccomp.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/util/Seccomp.c b/util/Seccomp.c
+index 9cd01b3..4a2065e 100644
+--- a/util/Seccomp.c
++++ b/util/Seccomp.c
+@@ -314,9 +314,13 @@ static struct sock_fprog* mkFilter(struct Allocator* alloc, struct Except* eh)
+ // Security_nofiles
+ IFEQ(__NR_setrlimit, success),
+
+- // for ETHInterface_listDevices (netlink)
++ // for ETHInterface_listDevices (netlinkk)
++ #ifdef __NR_bind
+ IFEQ(__NR_bind, bind_netlink),
++ #endif
++ #ifdef __NR_getsockname
+ IFEQ(__NR_getsockname, success),
++ #endif
+ RET(SECCOMP_RET_TRAP),
+
+ LABEL(socket),