summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-12-07 10:09:34 -0500
committerKevin MacMartin2015-12-07 10:09:34 -0500
commitbc627d29742fe728bcab5b7a7997ffd3d07f5a90 (patch)
treea0e1c8c37871dedb0d02c140ea676fa563c2630e
parent65136d4c4a4f815c86662ff363abc8edd5acca30 (diff)
downloadaur-bc627d29742fe728bcab5b7a7997ffd3d07f5a90.tar.gz
Update to 17.1.r83.g486ec91
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--seccomp-bind-getsockaddr.patch29
3 files changed, 6 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35bb3b2a52d3..d62ce001910d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cjdns-git
pkgdesc = A routing engine designed for security, scalability, speed and ease of use
- pkgver = 17.1.r72.g68693cc
- pkgrel = 2
+ pkgver = 17.1.r83.g486ec91
+ pkgrel = 1
url = https://github.com/cjdelisle/cjdns
arch = i686
arch = x86_64
@@ -21,9 +21,7 @@ pkgbase = cjdns-git
options = !strip
options = !buildflags
source = git+https://github.com/cjdelisle/cjdns#branch=crashey
- source = seccomp-bind-getsockaddr.patch
sha512sums = SKIP
- sha512sums = 547db6c204c029375fa435414dc3a15d4df3cb6d73a65ad7c9476454dc1cc5ded6cf5cfca75ccd580ed98b2ca4508127572eb4bd2d4c7847015c94c014bd18a4
pkgname = cjdns-git
diff --git a/PKGBUILD b/PKGBUILD
index 795a5800845b..1d21fea84361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
_pkgname=cjdns
pkgname=$_pkgname-git
-pkgver=17.1.r72.g68693cc
-pkgrel=2
+pkgver=17.1.r83.g486ec91
+pkgrel=1
pkgdesc='A routing engine designed for security, scalability, speed and ease of use'
url='https://github.com/cjdelisle/cjdns'
license=('GPL3')
@@ -20,19 +20,14 @@ optdepends=(
)
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+$url#branch=crashey" 'seccomp-bind-getsockaddr.patch')
-sha512sums=('SKIP' '547db6c204c029375fa435414dc3a15d4df3cb6d73a65ad7c9476454dc1cc5ded6cf5cfca75ccd580ed98b2ca4508127572eb4bd2d4c7847015c94c014bd18a4')
+source=("git+$url#branch=crashey")
+sha512sums=('SKIP')
pkgver() {
cd $_pkgname
git describe --tags | sed 's|^[^-]*-v||;s|-|.r|;s|-|.|g'
}
-prepare() {
- cd $_pkgname
- patch -p1 < ../seccomp-bind-getsockaddr.patch
-}
-
build() {
cd $_pkgname
bash 'do'
diff --git a/seccomp-bind-getsockaddr.patch b/seccomp-bind-getsockaddr.patch
deleted file mode 100644
index 5327bc000ddc..000000000000
--- a/seccomp-bind-getsockaddr.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 87d78ec488bfbbab3683b64c1c58b53b50c08803 Mon Sep 17 00:00:00 2001
-From: Kubuxu <kubuxu@gmail.com>
-Date: Tue, 1 Dec 2015 17:14:27 +0100
-Subject: [PATCH] SECCOMP: bind and getsockaddr do not exist Introduced in
- 3712d583b8ac7b940521d96107cb06
-
----
- util/Seccomp.c | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/util/Seccomp.c b/util/Seccomp.c
-index 9cd01b3..4a2065e 100644
---- a/util/Seccomp.c
-+++ b/util/Seccomp.c
-@@ -314,9 +314,13 @@ static struct sock_fprog* mkFilter(struct Allocator* alloc, struct Except* eh)
- // Security_nofiles
- IFEQ(__NR_setrlimit, success),
-
-- // for ETHInterface_listDevices (netlink)
-+ // for ETHInterface_listDevices (netlinkk)
-+ #ifdef __NR_bind
- IFEQ(__NR_bind, bind_netlink),
-+ #endif
-+ #ifdef __NR_getsockname
- IFEQ(__NR_getsockname, success),
-+ #endif
- RET(SECCOMP_RET_TRAP),
-
- LABEL(socket),