summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-11-25 18:51:06 -0500
committerKevin MacMartin2015-11-25 18:51:06 -0500
commit055a5d3c4bf2c95fc8a62dcb0a3cd31c53da584f (patch)
tree16420bc91f43308f3f97247fb58ccdbc8380bdcf
parent4f67a628736af58ffea0bb7e96a427c52631e12b (diff)
downloadaur-055a5d3c4bf2c95fc8a62dcb0a3cd31c53da584f.tar.gz
Depend on cjdns instead of cjdns-git, clean up the package a bit and include a gitignore
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0934ed24ba24..c1c2c1e7a79a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = cjdnsify
pkgdesc = Limit network access of bind-compatible programs to the local cjdns network
pkgver = 20140717.r6.bc354af
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/prurigro/cjdnsify
arch = any
license = GPL
makedepends = git
depends = bash
- depends = cjdns-git
+ depends = cjdns
depends = force_bind
backup = etc/default/cjdnsify
- source = git://github.com/prurigro/cjdnsify.git#branch=master
+ source = git://github.com/prurigro/cjdnsify.git
sha512sums = SKIP
pkgname = cjdnsify
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3fb4814f62ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+pkg
+src
+cjdnsify
diff --git a/PKGBUILD b/PKGBUILD
index 345908ed27a4..e7c54dd23e6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,24 @@
pkgname=cjdnsify
pkgver=20140717.r6.bc354af
-pkgrel=1
-pkgdesc="Limit network access of bind-compatible programs to the local cjdns network"
-url="https://github.com/prurigro/${pkgname}"
+pkgrel=2
+pkgdesc='Limit network access of bind-compatible programs to the local cjdns network'
+url='https://github.com/prurigro/cjdnsify'
license=('GPL')
-depends=('bash' 'cjdns-git' 'force_bind')
+depends=('bash' 'cjdns' 'force_bind')
makedepends=('git')
arch=('any')
-backup=("etc/default/${pkgname}")
-
-source=("git://github.com/prurigro/${pkgname}.git#branch=master")
+backup=("etc/default/$pkgname")
+source=("git://github.com/prurigro/$pkgname.git")
sha512sums=('SKIP')
pkgver() {
- cd $pkgname
- printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd $pkgname
- install -Dm755 $pkgname "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 ${pkgname}.conf "${pkgdir}/etc/default/${pkgname}"
+ cd $pkgname
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.conf "$pkgdir/etc/default/$pkgname"
}