summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLartza2017-06-10 10:30:27 +0300
committerLartza2017-06-10 10:30:27 +0300
commit41e3c40f58e07b2da4373f06563c6b595cb46dee (patch)
treefcb80ae2ee198c414e14c0a4834e312d4eb0ff2c
parentb697b6a405bb9ab181e78c23b67ae0a89a52367b (diff)
downloadaur-41e3c40f58e07b2da4373f06563c6b595cb46dee.tar.gz
Update build process
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD42
-rw-r--r--disable_version_checks.diff60
3 files changed, 7 insertions, 101 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c0d45d1774f..5c9a929af8db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Jun 22 18:13:31 UTC 2016
+# Sat Jun 10 07:26:23 UTC 2017
pkgbase = ckan-git
pkgdesc = A metadata repository and associated tools for searching, installing, and managing mods for Kerbal Space Program (KSP)
- pkgver = 1.18.0.r5.g0ab70f4
+ pkgver = 1.22.3.r0.g64309722
pkgrel = 1
url = https://github.com/KSP-CKAN/CKAN
arch = any
@@ -15,9 +15,7 @@ pkgbase = ckan-git
provides = ckan
conflicts = ckan
source = git://github.com/KSP-CKAN/CKAN
- source = disable_version_checks.diff
sha256sums = SKIP
- sha256sums = 21ed582d41da7f52ea4014fdcfadcadb7025f0fbae924fccd345c3b1f0fbff44
pkgname = ckan-git
diff --git a/PKGBUILD b/PKGBUILD
index 0902f8f87c63..77bf4fdf33b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Patrik Plihal <patrik.plihal@gmail.com>
pkgname=ckan-git
-pkgver=1.18.0.r5.g0ab70f4
+pkgver=1.22.3.r0.g64309722
pkgrel=1
pkgdesc="A metadata repository and associated tools for searching, installing, and managing mods for Kerbal Space Program (KSP)"
arch=('any')
@@ -13,52 +13,20 @@ provides=('ckan')
conflicts=('ckan')
depends=('mono' 'curl')
makedepends=('git' 'python2' 'python2-requests')
-source=('git://github.com/KSP-CKAN/CKAN'
- 'disable_version_checks.diff')
-sha256sums=('SKIP'
- '21ed582d41da7f52ea4014fdcfadcadb7025f0fbae924fccd345c3b1f0fbff44')
+source=('git://github.com/KSP-CKAN/CKAN')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/CKAN"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
-
- # ignore certain version checks that return "inconclusive" exceptions for development builds
- cd "$srcdir/CKAN/"
- git apply $srcdir/disable_version_checks.diff
-}
-
build() {
cd "$srcdir/CKAN"
- xbuild /verbosity:minimal CKAN.sln
-
- cd "$srcdir/CKAN/Cmdline"
- mono ../Core/packages/ILRepack.1.25.0/tools/ILRepack.exe \
- /target:exe \
- /out:$srcdir/ckan.exe \
- bin/Debug/CmdLine.exe \
- bin/Debug/CKAN-GUI.exe \
- bin/Debug/ChinhDo.Transactions.dll \
- bin/Debug/CKAN.dll \
- bin/Debug/CommandLine.dll \
- bin/Debug/ICSharpCode.SharpZipLib.dll \
- bin/Debug/log4net.dll \
- bin/Debug/Newtonsoft.Json.dll \
- bin/Debug/INIFileParser.dll \
- bin/Debug/CurlSharp.dll \
- bin/Debug/Autofac.dll
-}
-
-check() {
- #nunit-console4 is included in mono
-
- cd "$srcdir/CKAN/"
- command nunit-console4 --exclude=FlakyNetwork Tests/bin/Debug/CKAN.Tests.dll
+ ./build
}
package() {
mkdir -p "$pkgdir/usr/bin/"
- cp $srcdir/ckan.exe "$pkgdir/usr/bin/ckan"
+ cp $srcdir/CKAN/_build/ckan.exe "$pkgdir/usr/bin/ckan"
}
diff --git a/disable_version_checks.diff b/disable_version_checks.diff
deleted file mode 100644
index aeea4320cfe8..000000000000
--- a/disable_version_checks.diff
+++ /dev/null
@@ -1,60 +0,0 @@
-From 1cd782ff7bc2f4b10055b6e58ea4256843f3d873 Mon Sep 17 00:00:00 2001
-From: ChucklesTheBeard <ChucklesTheBeard+git@gmail.com>
-Date: Sun, 19 Jul 2015 20:40:09 -0400
-Subject: [PATCH] la
-
----
- Tests/Core/Meta.cs | 2 ++
- Tests/Core/Types/Module.cs | 4 +++-
- 2 files changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/Tests/Core/Meta.cs b/Tests/Core/Meta.cs
-index f2916be..b7b5504 100644
---- a/Tests/Core/Meta.cs
-+++ b/Tests/Core/Meta.cs
-@@ -8,6 +8,7 @@ namespace Tests.Core
- public class Meta
- {
- [Test]
-+ [Ignore]
- public void Version()
- {
- string version = CKAN.Meta.BuildVersion();
-@@ -23,6 +24,7 @@ namespace Tests.Core
- }
-
- [Test]
-+ [Ignore]
- public void ReleaseNumber()
- {
- Version version = CKAN.Meta.ReleaseNumber();
-diff --git a/Tests/Core/Types/Module.cs b/Tests/Core/Types/Module.cs
-index 6a9161a..3f4ba45 100644
---- a/Tests/Core/Types/Module.cs
-+++ b/Tests/Core/Types/Module.cs
-@@ -100,6 +100,7 @@ namespace Tests.Core.Types
- }
-
- [Test]
-+ [Ignore]
- public void IsSpecSupported()
- {
- if (CKAN.Meta.ReleaseNumber() == null)
-@@ -127,6 +128,7 @@ namespace Tests.Core.Types
- }
-
- [Test]
-+ [Ignore]
- public void FutureModule()
- {
- if (CKAN.Meta.ReleaseNumber() == null)
-@@ -187,4 +189,4 @@ namespace Tests.Core.Types
- );
- }
- }
--}
-\ No newline at end of file
-+}
---
-2.4.6
-