diff options
author | ChucklesTheBeard | 2015-06-22 18:49:47 -0400 |
---|---|---|
committer | ChucklesTheBeard | 2015-06-22 18:49:47 -0400 |
commit | 6feb7ea67859ca2cf8ae78911af7da950c0eab64 (patch) | |
tree | ef11db466fce7545cd935e650087f951bed452c5 | |
parent | c27184bce9bcbbbafe4b5b0535f295d11fe81de0 (diff) | |
download | aur-6feb7ea67859ca2cf8ae78911af7da950c0eab64.tar.gz |
Update to 1.8.2
tests were added, which invalidated disable_version_checks.diff. Updated.
Updated checksums (and switched to SHA-256 because I was told MD5 was broken)
-rw-r--r-- | PKGBUILD | 6 | ||||
-rw-r--r-- | disable_version_checks.diff | 29 |
2 files changed, 11 insertions, 24 deletions
@@ -5,7 +5,7 @@ # Contributer: Patrik Plihal <patrik.plihal@gmail.com> pkgname=ckan-git -pkgver=v1.6.22.r2.g72052f3 +pkgver=v1.8.2.r0.g0ff265c pkgrel=1 pkgdesc="A metadata repository and associated tools for searching, installing, and managing mods for Kerbal Space Program (KSP)" arch=('any') @@ -16,8 +16,8 @@ depends=('mono' 'curl') makedepends=('git' 'python2' 'python2-requests') source=('git://github.com/KSP-CKAN/CKAN' 'disable_version_checks.diff') -md5sums=('SKIP' - '0e79190f162aa2daf362b3c259e2e1fa') +sha256sums=('SKIP' + 'd3e9d65f577e2999f19ad49abed98a1f3dbbcbc56806ca746c45b4ee0c7f77cf') pkgver() { cd "$srcdir/CKAN" diff --git a/disable_version_checks.diff b/disable_version_checks.diff index dd602ca9a16..194deed2b24 100644 --- a/disable_version_checks.diff +++ b/disable_version_checks.diff @@ -1,22 +1,12 @@ -From c64466c743a3c1a278692226b959924098704710 Mon Sep 17 00:00:00 2001 -From: ChucklesTheBeard <ChucklesTheBeard+git@gmail.com> -Date: Mon, 1 Jun 2015 18:34:25 -0400 -Subject: [PATCH] ignore certain tests - ---- - Tests/Core/Meta.cs | 2 ++ - Tests/Core/Types/Module.cs | 4 +++- - 2 files changed, 5 insertions(+), 1 deletion(-) - diff --git a/Tests/Core/Meta.cs b/Tests/Core/Meta.cs -index f2916be..3ed2f5e 100644 +index f2916be..b7b5504 100644 --- a/Tests/Core/Meta.cs +++ b/Tests/Core/Meta.cs @@ -8,6 +8,7 @@ namespace Tests.Core public class Meta { [Test] -+ [Ignore] ++ [Ignore] public void Version() { string version = CKAN.Meta.BuildVersion(); @@ -24,19 +14,19 @@ index f2916be..3ed2f5e 100644 } [Test] -+ [Ignore] ++ [Ignore] public void ReleaseNumber() { Version version = CKAN.Meta.ReleaseNumber(); diff --git a/Tests/Core/Types/Module.cs b/Tests/Core/Types/Module.cs -index f94900a..d6bd106 100644 +index f640e77..2b00c54 100644 --- a/Tests/Core/Types/Module.cs +++ b/Tests/Core/Types/Module.cs @@ -84,6 +84,7 @@ namespace Tests.Core.Types } [Test] -+ [Ignore] ++ [Ignore] public void IsSpecSupported() { if (CKAN.Meta.ReleaseNumber() == null) @@ -44,17 +34,14 @@ index f94900a..d6bd106 100644 } [Test] -+ [Ignore] ++ [Ignore] public void FutureModule() { if (CKAN.Meta.ReleaseNumber() == null) -@@ -127,4 +129,4 @@ namespace Tests.Core.Types - +@@ -146,4 +148,4 @@ namespace Tests.Core.Types + Assert.AreEqual("GPL-3.0", mod.license[0].ToString()); } } -} \ No newline at end of file +} --- -2.4.2 - |