summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfunilrys2021-04-18 13:21:53 +0200
committerfunilrys2021-04-18 13:21:53 +0200
commit3c7f7f424f2a84674792f15cd26a00498c1ea679 (patch)
treec46179ebe6131532c0e414779b55b96630d923c8
parent15792de09a4e42f45c30a20c4e4b0b244b54c5d4 (diff)
downloadaur-3c7f7f424f2a84674792f15cd26a00498c1ea679.tar.gz
Update ckbcomp to v1.202
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD22
2 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b83fa28ceeff..fafa37742297 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = ckbcomp
pkgdesc = Compile a XKB keyboard description to a keymap suitable for loadkeys or kbdcontrol
- pkgver = 1.199
+ pkgver = 1.202
pkgrel = 1
url = http://anonscm.debian.org/cgit/d-i/console-setup.git/
arch = any
license = GPL2
depends = perl
- source = http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.199.tar.xz
- sha512sums = 8d969de9e6c300c799fb8c58c5300112c1576768c41cd29a9185ecbf0d5c5205356439b54141f00ef4e76ceaf3dc2106cb5fd3e9ec430a205183c07bea341d96
+ source = http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_1.202.tar.xz
+ sha512sums = caa7dcf667d44edab97811d8f95a3532af6d340e217e4a2acfa02f8812625522823e8d90bd35f701f3fc0b6c6e3b867a0a58c5c2323c64022f2c5ca3527e7d33
pkgname = ckbcomp
diff --git a/PKGBUILD b/PKGBUILD
index 8e1e5b7c5f92..4be5987089a9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Ex-Maintainer: Jeroen Bollen <jbinero at gmail dot comau>
pkgname=ckbcomp
-pkgver=1.199
+pkgver=1.202
pkgrel=1
pkgdesc="Compile a XKB keyboard description to a keymap suitable for loadkeys or kbdcontrol"
arch=(any)
@@ -10,10 +10,26 @@ url="http://anonscm.debian.org/cgit/d-i/console-setup.git/"
license=('GPL2')
depends=('perl')
source=("http://ftp.de.debian.org/debian/pool/main/c/console-setup/console-setup_${pkgver}.tar.xz")
-sha512sums=('8d969de9e6c300c799fb8c58c5300112c1576768c41cd29a9185ecbf0d5c5205356439b54141f00ef4e76ceaf3dc2106cb5fd3e9ec430a205183c07bea341d96')
+sha512sums=('caa7dcf667d44edab97811d8f95a3532af6d340e217e4a2acfa02f8812625522823e8d90bd35f701f3fc0b6c6e3b867a0a58c5c2323c64022f2c5ca3527e7d33')
package() {
- cd console-setup
+ if [[ -d "${srcdir}/console-setup" ]]
+ then
+ cd console-setup
+ elif [[ -d "${srcdir}/console-setup-${pkgver}" ]]
+ then
+ cd console-setup-${pkgver}
+ else
+ echo "Source directory not found.".
+ exit 1
+ fi
+
+
+ if [[ ${?} != 0 ]]
+ then
+ cd console-setup-${pkgver}
+ fi
+
install -d ${pkgdir}/usr/bin/
install -m755 Keyboard/ckbcomp ${pkgdir}/usr/bin/
}