summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormnovick19882016-01-28 22:16:29 -0500
committermnovick19882016-01-28 22:16:29 -0500
commita60c44994cc6f3a5ee0cf73cb05c1388546f8779 (patch)
treed02470f357b1ff83bec19d124fb5e39d3268caa2
downloadaur-a60c44994cc6f3a5ee0cf73cb05c1388546f8779.tar.gz
Initial import
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD76
-rw-r--r--clamd.conf6
-rw-r--r--clamd.service11
-rw-r--r--freshclam.conf3
-rw-r--r--freshclamd.service10
-rw-r--r--install15
-rw-r--r--logrotate10
-rw-r--r--tmpfiles.d1
9 files changed, 173 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78a48ad8d792
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+# Generated by mksrcinfo v8
+# Fri Jan 29 03:14:55 UTC 2016
+pkgbase = clamav-git
+ pkgdesc = Anti-virus toolkit for Unix
+ pkgver = 0.99.g1ab521a
+ pkgrel = 1
+ url = http://www.clamav.net/
+ install = install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libmilter
+ depends = bzip2
+ depends = libltdl
+ depends = gcc-libs
+ provides = clamav
+ provides = clamav-git
+ provides = clamav-devel
+ conflicts = clamav
+ conflicts = clamav-git
+ conflicts = clamav-devel
+ backup = etc/clamav/clamd.conf
+ backup = etc/clamav/freshclam.conf
+ backup = etc/logrotate.d/clamav
+ source = git+https://github.com/vrtadmin/clamav-devel.git
+ source = logrotate
+ source = tmpfiles.d
+ source = clamd.conf
+ source = freshclam.conf
+ source = clamd.service
+ source = freshclamd.service
+ sha1sums = SKIP
+ sha1sums = bb488a56b0f6a0760446cde89c1e3321e2717b78
+ sha1sums = a224ea9b4d0f4f196827347d54bed51e11c197ea
+ sha1sums = 887f624eb305f2446f55d8339e2972ad0cfe2b79
+ sha1sums = b767837d0279ad30b92c314cb762b73e5ad0415e
+ sha1sums = 77899cce83f04cbe134b30da376f879d2841f769
+ sha1sums = cda9a087e5593992150cb456e34c5f6f589aca82
+
+pkgname = clamav-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6163c4ee4b09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# $Id$
+# Contributor: Dale Blount <dale@archlinux.org>
+# Contributor: Gregor Ibic <gregor.ibic@intelicom.si>
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=clamav-git
+_gitname=clamav-devel
+pkgver=0.99.g1ab521a
+pkgrel=1
+pkgdesc='Anti-virus toolkit for Unix'
+url='http://www.clamav.net/'
+license=('GPL')
+arch=('i686' 'x86_64')
+provides=('clamav' 'clamav-git' 'clamav-devel')
+conflicts=('clamav' 'clamav-git' 'clamav-devel')
+makedepends=('libmilter')
+depends=('bzip2' 'libltdl' 'gcc-libs')
+validpgpkeys=('B964E6D7BC7D7C82CCB8D45840B8EA2364221D53'
+ 'F79FB2D08751574C5D3FDFFBB3D5342C260429A0')
+source=('git+https://github.com/vrtadmin/clamav-devel.git'
+ 'logrotate'
+ 'tmpfiles.d'
+ 'clamd.conf'
+ 'freshclam.conf'
+ 'clamd.service'
+ 'freshclamd.service')
+sha1sums=('SKIP'
+ 'bb488a56b0f6a0760446cde89c1e3321e2717b78'
+ 'a224ea9b4d0f4f196827347d54bed51e11c197ea'
+ '887f624eb305f2446f55d8339e2972ad0cfe2b79'
+ 'b767837d0279ad30b92c314cb762b73e5ad0415e'
+ '77899cce83f04cbe134b30da376f879d2841f769'
+ 'cda9a087e5593992150cb456e34c5f6f589aca82')
+
+backup=('etc/clamav/clamd.conf'
+ 'etc/clamav/freshclam.conf'
+ 'etc/logrotate.d/clamav')
+
+install=install
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ #_curtag="$(git rev-list --tags --max-count=1)"
+ #_tagver="$(git describe --tags $_curtag | sed -e 's:^v::' -e 's:-:_:g')"
+ #_commits="$(git rev-list --count HEAD --since=$_tagver)"
+ #_sha="$(git rev-parse --short HEAD)"
+ #printf "%s_%s_g%s" $_tagver $_commits $_sha
+ echo "0.99.g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc/clamav \
+ --with-dbdir=/var/lib/clamav \
+ --enable-milter \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 ../clamd.conf "${pkgdir}"/etc/clamav/clamd.conf
+ install -Dm644 ../freshclam.conf "${pkgdir}"/etc/clamav/freshclam.conf
+ install -Dm644 ../freshclamd.service "${pkgdir}"/usr/lib/systemd/system/freshclamd.service
+ install -Dm644 ../clamd.service "${pkgdir}"/usr/lib/systemd/system/clamd.service
+ install -Dm644 ../tmpfiles.d "${pkgdir}"/usr/lib/tmpfiles.d/clamav.conf
+ install -Dm644 ../logrotate "${pkgdir}"/etc/logrotate.d/clamav
+
+ install -d -o 64 -g 64 "${pkgdir}"/var/log/clamav
+ install -d -o 64 -g 64 "${pkgdir}"/var/lib/clamav
+}
diff --git a/clamd.conf b/clamd.conf
new file mode 100644
index 000000000000..d231ec9f0f97
--- /dev/null
+++ b/clamd.conf
@@ -0,0 +1,6 @@
+LogFile /var/log/clamav/clamd.log
+LogTime yes
+PidFile /run/clamav/clamd.pid
+TemporaryDirectory /tmp
+LocalSocket /var/lib/clamav/clamd.sock
+User clamav
diff --git a/clamd.service b/clamd.service
new file mode 100644
index 000000000000..ac9e789aec82
--- /dev/null
+++ b/clamd.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=clamav daemon
+After=network.target
+
+[Service]
+Type=forking
+PIDFile=/run/clamav/clamd.pid
+ExecStart=/usr/bin/clamd
+
+[Install]
+WantedBy=multi-user.target
diff --git a/freshclam.conf b/freshclam.conf
new file mode 100644
index 000000000000..db513fd3eadc
--- /dev/null
+++ b/freshclam.conf
@@ -0,0 +1,3 @@
+UpdateLogFile /var/log/clamav/freshclam.log
+DatabaseMirror database.clamav.net
+NotifyClamd /etc/clamav/clamd.conf
diff --git a/freshclamd.service b/freshclamd.service
new file mode 100644
index 000000000000..a0a72c2e60eb
--- /dev/null
+++ b/freshclamd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=clamav updater
+
+[Service]
+Type=forking
+PIDFile=/run/clamav/freshclam.pid
+ExecStart=/usr/bin/freshclam -d -p /run/clamav/freshclam.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/install b/install
new file mode 100644
index 000000000000..1a0653e2a1f7
--- /dev/null
+++ b/install
@@ -0,0 +1,15 @@
+post_upgrade() {
+ systemd-tmpfiles --create clamav.conf
+}
+
+post_install() {
+ getent group clamav &>/dev/null || groupadd -r -g 64 clamav >/dev/null
+ getent passwd clamav &>/dev/null || useradd -r -u 64 -g clamav -d /dev/null -s /bin/false -c "Clam AntiVirus" clamav >/dev/null
+ post_upgrade
+}
+
+post_remove() {
+ getent passwd clamav &>/dev/null && userdel clamav >/dev/null
+ getent group clamav &>/dev/null && groupdel clamav >/dev/null
+ return 0
+}
diff --git a/logrotate b/logrotate
new file mode 100644
index 000000000000..5f6d87d29a6e
--- /dev/null
+++ b/logrotate
@@ -0,0 +1,10 @@
+/var/log/clamav/clamd.log /var/log/clamav/freshclam.log {
+ create 644 clamav clamav
+ sharedscripts
+ missingok
+ notifempty
+ postrotate
+ /bin/kill -HUP `cat /run/clamav/clamd.pid 2>/dev/null` 2> /dev/null || true
+ /bin/kill -HUP `cat /run/clamav/freshclam.pid 2>/dev/null` 2> /dev/null || true
+ endscript
+}
diff --git a/tmpfiles.d b/tmpfiles.d
new file mode 100644
index 000000000000..22d29941ea02
--- /dev/null
+++ b/tmpfiles.d
@@ -0,0 +1 @@
+d /run/clamav 0755 clamav clamav