summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-12-18 21:38:08 +0000
committerAntonio Rojas2017-12-18 21:38:08 +0000
commit86ebb46b00ccb071078a5aeb272ded1d4869d655 (patch)
tree09ee31778f6ca0292482247c357805c3b3557386
downloadaur-86ebb46b00ccb071078a5aeb272ded1d4869d655.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..182ada6ea6a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = clamz
+ pkgdesc = Command-line program to download MP3 files from Amazon.com's music store.
+ pkgver = 0.5
+ pkgrel = 3
+ url = http://code.google.com/p/clamz/
+ arch = x86_64
+ license = GPL3
+ depends = libgcrypt
+ depends = curl
+ depends = expat
+ depends = shared-mime-info
+ depends = desktop-file-utils
+ source = http://clamz.googlecode.com/files/clamz-0.5.tar.gz
+ md5sums = 84543c9346b285bdc218879e241941a8
+
+pkgname = clamz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f89491f1c0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=clamz
+pkgver=0.5
+pkgrel=3
+pkgdesc="Command-line program to download MP3 files from Amazon.com's music store."
+arch=('x86_64')
+url='http://code.google.com/p/clamz/'
+license=('GPL3')
+depends=('libgcrypt' 'curl' 'expat' 'shared-mime-info' 'desktop-file-utils')
+source=("http://clamz.googlecode.com/files/clamz-${pkgver}.tar.gz")
+md5sums=('84543c9346b285bdc218879e241941a8')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ # Fix issue with update-mime-database
+ sed -i 's|$(UPDATE_DESKTOP_DATABASE)\ $(DESTDIR)$(applications_dir)||' Makefile.in
+ sed -i 's|$(UPDATE_MIME_DATABASE)\ $(DESTDIR)$(mime_dir)||' Makefile.in
+
+ ./configure --prefix=/usr/
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}