summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarenome Ranaivoarivony-Razanajato2017-03-20 00:47:29 +0100
committerHarenome Ranaivoarivony-Razanajato2017-03-20 00:47:29 +0100
commit9057a5c493b47520df1deefb804a52a8d2b0482d (patch)
tree792a067745c52c1303f4e72d70b0b6c36cd27211
downloadaur-9057a5c493b47520df1deefb804a52a8d2b0482d.tar.gz
clan 0.8.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD38
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e32b14c0e1bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = clan
+ pkgdesc = Chunky Loop Analyzer: A Polyhedral Representation Extraction Tool for High Level Programs
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/index.html
+ arch = x86_64
+ license = LGPL
+ depends = osl
+ provides = clan
+ source = http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/docs/clan-0.8.0.tar.gz
+ md5sums = 0dcba7f4bdf32159405f27ebce439d63
+
+pkgname = clan
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2f8ab8cdc1ef
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+# As advised in the arch wiki page for AUR, ignore everything.
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c550b6958981
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Harenome Ranaivoarivony-Razanajato
+# <ranaivoarivony-razanajato@hareno.me>
+
+pkgname=clan
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Chunky Loop Analyzer: A Polyhedral Representation Extraction Tool for High Level Programs"
+arch=(x86_64)
+url="http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/index.html"
+license=('LGPL')
+depends=("osl")
+provides=("clan")
+source=(http://icps.u-strasbg.fr/people/bastoul/public_html/development/clan/docs/${pkgname}-${pkgver}.tar.gz)
+md5sums=('0dcba7f4bdf32159405f27ebce439d63')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ # The configure script's '--with-osl=system' option is buggy. The definitions
+ # of OSL_LIBS differ depending on the value of '--with-osl' but all of them
+ # can be overriden since the script will be called with '--with-osl=system'...
+ sed -i 's/OSL_LIBS=.*/OSL_LIBS=" -losl"/' configure
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --with-osl=system
+ make
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make check
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+}