summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuchesar V. ILIEV2017-09-28 17:57:28 +0300
committerLuchesar V. ILIEV2017-09-28 17:59:06 +0300
commit134973710062c378df3e8d6ea4e64dcb205071aa (patch)
tree0b220cdc3cdd3bb55f6bd5d552a86318b17061af
parent283956cb89330fc068077b990f8125669dbc45ff (diff)
downloadaur-134973710062c378df3e8d6ea4e64dcb205071aa.tar.gz
Fix conflicting 'six.py' #16
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c7ef83c6f153..c4e8ccc62668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -338,7 +338,7 @@ package_lldb-svn() {
"llvm-libs-svn=${pkgver}-${pkgrel}"
'libedit'
'libxml2'
- 'python2'
+ 'python2-six'
)
groups=('llvm-toolchain-svn')
provides=('lldb')
@@ -348,6 +348,10 @@ package_lldb-svn() {
make DESTDIR="${pkgdir}" install
+ # Clean up conflicting files
+ # TODO: This should probably be discussed with upstream.
+ rm -rf "${pkgdir}/usr/lib/python2.7/site-packages/six.py"
+
_fix_python_exec_path \
"${pkgdir}${_py_sitepkg_dir}/lldb/utils/symbolication.py"