summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuchesar V. ILIEV2017-10-28 18:00:37 +0300
committerLuchesar V. ILIEV2017-10-28 18:01:34 +0300
commit3d9af586437d8296efb51197cf3bac6c693cd8b7 (patch)
treeff796b1b08463a0f3b5ca483824fa6b495134f93
parent6d7f37cdb1551788df4bebd727ac096fda318360 (diff)
downloadaur-3d9af586437d8296efb51197cf3bac6c693cd8b7.tar.gz
Temporary fix for LLVM bug 35053
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7804a659f646..afd990b9565f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -181,6 +181,12 @@ build() {
export PKG_CONFIG_PATH='/usr/lib/pkgconfig'
+ # FIXME: Temporary fix for LLVM bug 35053:
+ # "error: undefined reference to 'pthread_atfork'"
+ # Ref: https://bugs.llvm.org/show_bug.cgi?id=35053
+ # Credit: SolarAquarion @ AUR
+ export LDFLAGS="${LDFLAGS} -pthread -lpthread -lm"
+
# LLVM_BUILD_LLVM_DYLIB: Build the dynamic runtime libraries (e.g. libLLVM.so).
# LLVM_LINK_LLVM_DYLIB: Link our own tools against the libLLVM dynamic library, too.
# LLVM_BINUTILS_INCDIR: Set to binutils' plugin-api.h location in order to build LLVMgold.