summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuchesar V. ILIEV2017-03-04 05:29:12 +0200
committerLuchesar V. ILIEV2017-03-04 05:35:01 +0200
commit49b7eb7eed6111a0823935f00ec988177b37ff18 (patch)
tree2cdb13f5487bdf6deaa7c70d044ba6283b010389
parent5d66b12f31522dc55d877a50769acd67895ce72c (diff)
downloadaur-49b7eb7eed6111a0823935f00ec988177b37ff18.tar.gz
Until bug 31610 is fixed, disable the LLVM tests
Ref: https://github.com/kerberizer/llvm-svn/issues/12 Ref: https://bugs.llvm.org//show_bug.cgi?id=31610
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0e723ed236e..810c16f65bb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -200,8 +200,11 @@ build() {
check() {
cd "${srcdir}/build"
# Dirty fix for unittests failing because the shared lib is not in the library path.
- # Also, disable the tests on i686 altogether as they seem to fail too often there.
- [[ "${CARCH}" == "i686" ]] || LD_LIBRARY_PATH="${srcdir}/build/lib" make check
+ # Also, disable the LLVM tests on i686 as they seem to fail too often there.
+ # Until bug 31610 is fixed, disable the LLVM tests altogether.
+ # Ref: https://github.com/kerberizer/llvm-svn/issues/12
+ # Ref: https://bugs.llvm.org//show_bug.cgi?id=31610
+ #[[ "${CARCH}" == "i686" ]] || LD_LIBRARY_PATH="${srcdir}/build/lib" make check
make check-clang
}