summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2021-06-06 15:24:00 +0200
committerJose Riha2021-06-06 15:24:00 +0200
commitcf5bfcc4b6da8bba6be2dae50b074de30d13b09b (patch)
tree22ef7d3ecc1c1aae33aa671e2627fb0fbbd48ed3
parent105b5014b1ed2be359019ab427d47663c9437eef (diff)
downloadaur-cf5bfcc4b6da8bba6be2dae50b074de30d13b09b.tar.gz
Update source, fix compilation
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
-rw-r--r--include_cstddef.patch12
3 files changed, 44 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c23c4b1ee33..49f7dc3aa48f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clanlib10
pkgdesc = A multi-platform game development library (legacy version)
- pkgver = 1.0.0
- pkgrel = 2
+ pkgver = 1.0svn3827
+ pkgrel = 3
url = http://clanlib.org/
arch = i686
arch = x86_64
@@ -19,8 +19,11 @@ pkgbase = clanlib10
conflicts = clanlib
conflicts = clanlib-svn
options = !libtool
- source = http://clanlib.org/download/releases-1.0/ClanLib-1.0.0.tgz
- md5sums = 281e64a463155474d0f1270686286811
+ source = https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/clanlib/1.0~svn3827-8/clanlib_1.0~svn3827.orig.tar.gz
+ source = https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/clanlib/1.0~svn3827-8/clanlib_1.0~svn3827-8.debian.tar.xz
+ source = include_cstddef.patch
+ md5sums = 0ee29d0aeeee5e993543320a6148b372
+ md5sums = 13d3f177489c2f5255249d77ab361a8f
+ md5sums = e314140173980004bd1dbb91d25e8669
pkgname = clanlib10
-
diff --git a/PKGBUILD b/PKGBUILD
index ba9920e51b71..12d9682ac284 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Jose Riha <jose1711 gmail com>
pkgname=clanlib10
-pkgver=1.0.0
-pkgrel=2
+pkgver=1.0svn3827
+pkgrel=3
pkgdesc="A multi-platform game development library (legacy version)"
arch=('i686' 'x86_64')
url="http://clanlib.org/"
@@ -12,27 +12,35 @@ depends=('alsa-lib' 'libjpeg' 'libmikmod' 'libpng12'
'libvorbis' 'libxi' 'libxxf86vm' 'mesa' 'sdl_gfx' 'glu')
conflicts=('clanlib' 'clanlib-svn')
options=('!libtool')
-source=("http://clanlib.org/download/releases-1.0/ClanLib-${pkgver}.tgz")
-md5sums=('281e64a463155474d0f1270686286811')
+# source=("http://clanlib.org/download/releases-1.0/ClanLib-${pkgver}.tgz")
+source=("https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/clanlib/1.0~svn3827-8/clanlib_1.0~svn3827.orig.tar.gz"
+ "https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/clanlib/1.0~svn3827-8/clanlib_1.0~svn3827-8.debian.tar.xz"
+ "include_cstddef.patch")
+md5sums=('0ee29d0aeeee5e993543320a6148b372'
+ '13d3f177489c2f5255249d77ab361a8f'
+ 'e314140173980004bd1dbb91d25e8669')
-build() {
- cd "${srcdir}/ClanLib-${pkgver}"
-
- # Fix for libpng 1.2
- sed -i "s_-lpng_-lpng12_" configure.ac
- sed -i "s_<png.h>_<libpng12/png.h>_" Sources/Display/Providers/png_provider_generic.h
-
- # Fix compilation errors
- sed -i "51i#include <cstdio>" Sources/GL/canvas_opengl.cpp
- sed -i "38i#include <cstdio>" Sources/GL/GLX/input_device_linuxevent.cpp
- sed -i "32i#include <cstdio>" Sources/GL/GLX/input_device_xinput.cpp
+prepare() {
+ cd "${srcdir}/clanlib-1.0~svn3827"
+ while read -r rule
+ do
+ patch -p1 -i "${srcdir}/debian/patches/${rule}"
+ done < "${srcdir}/debian/patches/series"
+ patch -p2 -i "${srcdir}/include_cstddef.patch"
+}
+build() {
+ cd "${srcdir}/clanlib-1.0~svn3827"
+ aclocal
+ libtoolize
+ automake --add-missing
+ autoconf
./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/ClanLib-${pkgver}"
+ cd "${srcdir}/clanlib-1.0~svn3827"
make DESTDIR="${pkgdir}" install
# Install a license file
diff --git a/include_cstddef.patch b/include_cstddef.patch
new file mode 100644
index 000000000000..f38c399ddfef
--- /dev/null
+++ b/include_cstddef.patch
@@ -0,0 +1,12 @@
+diff -aur src.orig/clanlib-1.0~svn3827/Sources/API/Core/System/cl_assert.h src/clanlib-1.0~svn3827/Sources/API/Core/System/cl_assert.h
+--- src.orig/clanlib-1.0~svn3827/Sources/API/Core/System/cl_assert.h 2021-06-06 15:17:41.575014216 +0200
++++ src/clanlib-1.0~svn3827/Sources/API/Core/System/cl_assert.h 2021-06-06 15:17:53.545055365 +0200
+@@ -29,6 +29,8 @@
+
+ //! clanCore="System"
+ //! header=core.h
++//
++#include <cstddef>
+
+ #ifndef header_cl_assert
+ #define header_cl_assert