summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSainnhepark2020-08-03 18:36:36 +0800
committerSainnhepark2020-08-03 18:36:36 +0800
commit2a6b6d1b3cf30122369fd07861c8ef64476b4a39 (patch)
treedcb2cfe61bf35fcdec973e280e191a7d32092f99
parent3c3ff9518c789c8cd39459bb4be3986540f7e27f (diff)
downloadaur-2a6b6d1b3cf30122369fd07861c8ef64476b4a39.tar.gz
remove hook
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--clap-neovim-doc.hook11
-rw-r--r--clap-vim-doc.hook11
4 files changed, 4 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9325eeffae2f..a71dd498681e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,11 +9,7 @@ pkgbase = clap-git
makedepends = rustup
makedepends = make
source = clap::git+https://github.com/liuchengxu/vim-clap.git
- source = clap-vim-doc.hook
- source = clap-neovim-doc.hook
sha256sums = SKIP
- sha256sums = 0fe8cf209778fb3345886a43393cfda53e5c5e4a09d8b09a049e892ba9c33acf
- sha256sums = 058b32ca0ec551c0742119b277a3e3f9bbac3031183fbf3d0a248fa2597adb97
pkgname = vim-clap-git
depends = vim
diff --git a/PKGBUILD b/PKGBUILD
index 397103494409..2e8ba7d9100a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,8 @@ pkgdesc='Modern performant generic finder and dispatcher for Vim and NeoVim'
arch=('any')
url='https://github.com/liuchengxu/vim-clap'
license=('MIT')
-source=("${_pkgname}::git+https://github.com/liuchengxu/vim-clap.git"
- "${_pkgname}-vim-doc.hook"
- "${_pkgname}-neovim-doc.hook")
-sha256sums=('SKIP'
- '0fe8cf209778fb3345886a43393cfda53e5c5e4a09d8b09a049e892ba9c33acf'
- '058b32ca0ec551c0742119b277a3e3f9bbac3031183fbf3d0a248fa2597adb97')
+source=("${_pkgname}::git+https://github.com/liuchengxu/vim-clap.git")
+sha256sums=('SKIP')
makedepends=('git'
'rustup'
'make')
@@ -27,7 +23,6 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
make
- touch doc/tags
}
package_vim-clap-git() {
@@ -42,13 +37,13 @@ package_vim-clap-git() {
_variant='vim'
cd "${srcdir}/${_pkgname}"
+ vim -es --cmd ":helptags doc" --cmd ":q"
find autoload doc ftplugin plugin pythonx/clap/fuzzymatch_rs.so pythonx/clap/*.py syntax -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
install -Dm 755 "${srcdir}/${_pkgname}/target/release/maple" \
"${pkgdir}/${_packdir}/bin/maple"
install -Dm 644 "${srcdir}/${_pkgname}/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 "${srcdir}/${_pkgname}-${_variant}-doc.hook" "${pkgdir}/usr/share/libalpm/hooks/${_pkgname}-${_variant}-doc.hook"
}
package_neovim-clap-git() {
@@ -63,11 +58,11 @@ package_neovim-clap-git() {
_variant='neovim'
cd "${srcdir}/${_pkgname}"
+ nvim -es --cmd ":helptags doc" --cmd ":q"
find autoload doc ftplugin plugin pythonx/clap/fuzzymatch_rs.so pythonx/clap/*.py syntax -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
install -Dm 755 "${srcdir}/${_pkgname}/target/release/maple" \
"${pkgdir}/${_packdir}/bin/maple"
install -Dm 644 "${srcdir}/${_pkgname}/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 "${srcdir}/${_pkgname}-${_variant}-doc.hook" "${pkgdir}/usr/share/libalpm/hooks/${_pkgname}-${_variant}-doc.hook"
}
diff --git a/clap-neovim-doc.hook b/clap-neovim-doc.hook
deleted file mode 100644
index 59323e6b0e77..000000000000
--- a/clap-neovim-doc.hook
+++ /dev/null
@@ -1,11 +0,0 @@
-[Trigger]
-Operation = Install
-Operation = Upgrade
-Operation= Remove
-Type = Path
-Target = usr/local/share/nvim/site/pack/clap/start/clap/doc/
-
-[Action]
-Description = Updating Vim help tags...
-Exec = /usr/bin/nvim -es --cmd ":helptags /usr/local/share/nvim/site/pack/clap/start/clap/doc" --cmd ":q"
-When = PostTransaction
diff --git a/clap-vim-doc.hook b/clap-vim-doc.hook
deleted file mode 100644
index 1b60b1465311..000000000000
--- a/clap-vim-doc.hook
+++ /dev/null
@@ -1,11 +0,0 @@
-[Trigger]
-Operation = Install
-Operation = Upgrade
-Operation= Remove
-Type = Path
-Target = usr/share/vim/vimfiles/pack/clap/start/clap/doc/
-
-[Action]
-Description = Updating Vim help tags...
-Exec = /usr/bin/vim -es --cmd ":helptags /usr/share/vim/vimfiles/pack/clap/start/clap/doc" --cmd ":q"
-When = PostTransaction