summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsp1rit2021-02-27 14:24:37 +0100
committersp1rit2021-02-27 14:24:37 +0100
commit564b682c4ea9cecb1bcd987d1855ad6020c43cf4 (patch)
treee44c11a6264cb3e34c422de2f0c068cfdbfaa6f0
downloadaur-564b682c4ea9cecb1bcd987d1855ad6020c43cf4.tar.gz
Initial package, version 0.1.0
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD68
2 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba762c75289d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = clapper
+ pkgdesc = A GNOME media player built using GJS with GTK4 toolkit and powered by GStreamer with OpenGL rendering.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/Rafostar/clapper
+ arch = any
+ license = GPL-3.0
+ makedepends = meson>=0.50
+ makedepends = git
+ makedepends = gobject-introspection
+ depends = gtk4
+ depends = gjs
+ depends = glib2>=2.56.0
+ depends = wayland-protocols
+ depends = hicolor-icon-theme
+ depends = gstreamer>=1.18.0
+ depends = gst-plugins-base-libs>=1.18.0
+ depends = gst-plugins-good>=1.18.0
+ depends = gst-plugins-bad-libs>=1.18.0
+ optdepends = gst-libav>=1.18.0: Popular video decoders
+ optdepends = gstreamer-vaapi>=1.18.0: Intel/AMD video acceleration
+ provides = clapper
+ provides = libgstclapper-1.0
+ conflicts = clapper
+ source = clapper-0.1.0::https://github.com/Rafostar/clapper/archive/0.1.0.tar.gz
+ md5sums = SKIP
+
+pkgname = clapper
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53e7a00ed90b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+#
+# PKGBUILD file for package clapper
+#
+# Copyright (C) 2020/21 sp1rit
+# Copyright (C) 2020 Rafostar
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+# Maintainer: sp1rit <sp1ritCS@protonmail.com>
+
+_basename=clapper
+pkgname="${_basename}"
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A GNOME media player built using GJS with GTK4 toolkit and powered by GStreamer with OpenGL rendering."
+arch=(any)
+url="https://github.com/Rafostar/clapper"
+license=("GPL-3.0")
+depends=(
+ "gtk4"
+ "gjs"
+ "glib2>=2.56.0" # glib-2.0, gmodule-2.0, gio-2.0
+ "wayland-protocols" # gtk4 non-default runtime dep
+ "hicolor-icon-theme"
+ "gstreamer>=1.18.0" # gstreamer-1.0, gstreamer-base-1.0
+ "gst-plugins-base-libs>=1.18.0" # gstreamer-pbutils-1.0, gstreamer-audio-1.0, gstreamer-tag-1.0, gstreamer-video-1.0, gstreamer-gl-1.0, gstreamer-gl-prototypes-1.0, gstreamer-gl-x11-1.0, gstreamer-gl-wayland-1.0, gstreamer-gl-egl-1.0,
+ "gst-plugins-good>=1.18.0"
+ "gst-plugins-bad-libs>=1.18.0"
+)
+makedepends=(
+ "meson>=0.50"
+ "git"
+ "gobject-introspection" # /usr/sbin/g-ir-scanner
+)
+optdepends=(
+ "gst-libav>=1.18.0: Popular video decoders"
+ "gstreamer-vaapi>=1.18.0: Intel/AMD video acceleration"
+)
+source=("${_basename}-${pkgver}::https://github.com/Rafostar/${_basename}/archive/${pkgver}.tar.gz")
+provides=("${_basename}" "libgst${_basename}-1.0")
+conflicts=("${_basename}")
+md5sums=("SKIP")
+
+prepare() {
+ cd "${srcdir}/${_basename}-${pkgver}"
+ arch-meson . _build
+}
+
+build() {
+ cd "${srcdir}/${_basename}-${pkgver}"
+ ninja -C _build
+}
+
+package() {
+ cd "${srcdir}/${_basename}-${pkgver}"
+ DESTDIR="$pkgdir" meson install -C _build/
+}