summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsp1rit2021-02-27 14:23:19 +0100
committersp1rit2021-02-27 14:23:19 +0100
commit9473b71ec525857b73a57c6bce145c4ed1c3e634 (patch)
tree8ac14a57bff5fd893b558cd3c680c7698043b7aa
parent4082e08ad5d7367d6a0bf5c4ab962ed9883d60c2 (diff)
downloadaur-9473b71ec525857b73a57c6bce145c4ed1c3e634.tar.gz
fixed a few issues @yochananmarqos requested
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 377a218fb9d..607173a8ca1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = clapper-git
pkgdesc = A GNOME media player built using GJS with GTK4 toolkit and powered by GStreamer with OpenGL rendering.
- pkgver = r393.bf04af2
+ pkgver = r509.f4968e2
pkgrel = 1
url = https://github.com/Rafostar/clapper
arch = any
license = GPL-3.0
makedepends = meson>=0.50
makedepends = git
+ makedepends = gobject-introspection
depends = gtk4
depends = gjs
depends = glib2>=2.56.0
- depends = gobject-introspection
depends = wayland-protocols
depends = hicolor-icon-theme
depends = gstreamer>=1.18.0
@@ -20,8 +20,8 @@ pkgbase = clapper-git
optdepends = gst-libav>=1.18.0: Popular video decoders
optdepends = gstreamer-vaapi>=1.18.0: Intel/AMD video acceleration
provides = clapper
+ provides = libgstclapper-1.0
conflicts = clapper
- replaces = clapper
source = clapper::git+https://github.com/Rafostar/clapper.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4a17195e67c..8a5127ed6bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@
_basename=clapper
pkgname="${_basename}-git"
-pkgver=r393.bf04af2
+pkgver=r509.f4968e2
pkgrel=1
pkgdesc="A GNOME media player built using GJS with GTK4 toolkit and powered by GStreamer with OpenGL rendering."
arch=(any)
@@ -31,7 +31,6 @@ depends=(
"gtk4"
"gjs"
"glib2>=2.56.0" # glib-2.0, gmodule-2.0, gio-2.0
- "gobject-introspection" # /usr/sbin/g-ir-scanner
"wayland-protocols" # gtk4 non-default runtime dep
"hicolor-icon-theme"
"gstreamer>=1.18.0" # gstreamer-1.0, gstreamer-base-1.0
@@ -42,14 +41,14 @@ depends=(
makedepends=(
"meson>=0.50"
"git"
+ "gobject-introspection" # /usr/sbin/g-ir-scanner
)
optdepends=(
"gst-libav>=1.18.0: Popular video decoders"
"gstreamer-vaapi>=1.18.0: Intel/AMD video acceleration"
)
source=("${_basename}::git+https://github.com/Rafostar/${_basename}.git")
-provides=("${_basename}")
-replaces=("${_basename}")
+provides=("${_basename}" "libgst${_basename}-1.0")
conflicts=("${_basename}")
md5sums=("SKIP")