summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-02-27 11:22:23 +0800
committerSukanka2022-02-27 11:22:23 +0800
commitcb3471487af94fd5844f24ead6bcce14c38c09fa (patch)
tree2d9a0300ad87dbc5c7a2a2217a5d99e2057edad6
parentf124c79073f8a4a823f5d3b51185d4b2a7f7b6c4 (diff)
downloadaur-cb3471487af94fd5844f24ead6bcce14c38c09fa.tar.gz
update r15
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--arch.patch36
-rw-r--r--clash-premium-script.install11
4 files changed, 27 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d3ff648fe98..17921615cfff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clash-premium-script
pkgdesc = Simple clash premium core script for Linux.
- pkgver = r11.e729951
- pkgrel = 2
+ pkgver = r15.c2b80f9
+ pkgrel = 1
url = https://github.com/Kr328/clash-premium-installer
install = clash-premium-script.install
arch = any
@@ -17,7 +17,7 @@ pkgbase = clash-premium-script
source = arch.patch
source = config.yaml
sha256sums = SKIP
- sha256sums = b12839b50154a1ff31fa6aa2e9de482ddd9a2bcd45a83bed0fae11549d479646
- sha256sums = 1938bc7544f8e33a6e41636f45e87a17de2eac0ca14f47c2f7a71c3c87341bf0
+ sha256sums = 6af9092581610933b96641155769dd92c1f0d6d918b0f8cf0cd9f8a583d18f38
+ sha256sums = e172230e94128e4b98b7c610a74cda8cf7e7dd33672ad2c23fe5fc8d295bd6ed
pkgname = clash-premium-script
diff --git a/PKGBUILD b/PKGBUILD
index 37a8f237ea6f..91cf6bd6990d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=clash-premium-script
_pkgname=clash-premium-installer
-pkgver=r11.e729951
-pkgrel=2
+pkgver=r15.c2b80f9
+pkgrel=1
pkgdesc="Simple clash premium core script for Linux."
arch=('any')
url="https://github.com/Kr328/clash-premium-installer"
@@ -15,15 +15,15 @@ backup=("etc/clash/config.yaml" "etc/default/clash")
source=("git+https://github.com/Kr328/clash-premium-installer.git"
"arch.patch"
"config.yaml")
-sha256sums=('SKIP'
- 'b12839b50154a1ff31fa6aa2e9de482ddd9a2bcd45a83bed0fae11549d479646'
- '1938bc7544f8e33a6e41636f45e87a17de2eac0ca14f47c2f7a71c3c87341bf0')
+sha256sums=('SKIP'
+ '6af9092581610933b96641155769dd92c1f0d6d918b0f8cf0cd9f8a583d18f38'
+ 'e172230e94128e4b98b7c610a74cda8cf7e7dd33672ad2c23fe5fc8d295bd6ed')
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-
+
prepare() {
cd "${srcdir}"/clash-premium-installer/
git apply ../arch.patch
diff --git a/arch.patch b/arch.patch
index 023d7514daed..eae84376acf4 100644
--- a/arch.patch
+++ b/arch.patch
@@ -1,16 +1,14 @@
-diff --git a/scripts/99-clash.rules b/scripts/99-clash.rules
-index a73d507..9d77338 100644
---- a/scripts/99-clash.rules
-+++ b/scripts/99-clash.rules
+diff --color --unified --recursive --text a/scripts/99-clash.rules b/scripts/99-clash.rules
+--- a/scripts/99-clash.rules 2022-02-27 11:13:08.792924323 +0800
++++ b/scripts/99-clash.rules 2022-02-27 11:14:14.628805349 +0800
@@ -1,2 +1,2 @@
-SUBSYSTEM=="net",ENV{INTERFACE}=="utun",ACTION=="add",RUN+="/usr/lib/clash/setup-tun.sh"
-SUBSYSTEM=="net",ENV{INTERFACE}=="utun",ACTION=="remove",RUN+="/usr/lib/clash/clean-tun.sh"
+SUBSYSTEM=="net",ENV{INTERFACE}=="utun",ACTION=="add",RUN+="/usr/share/clash/setup-tun.sh"
+SUBSYSTEM=="net",ENV{INTERFACE}=="utun",ACTION=="remove",RUN+="/usr/share/clash/clean-tun.sh"
-diff --git a/scripts/bypass-proxy b/scripts/bypass-proxy
-index 606c4f1..cab10be 100755
---- a/scripts/bypass-proxy
-+++ b/scripts/bypass-proxy
+diff --color --unified --recursive --text a/scripts/bypass-proxy b/scripts/bypass-proxy
+--- a/scripts/bypass-proxy 2022-02-27 11:13:08.792924323 +0800
++++ b/scripts/bypass-proxy 2022-02-27 11:14:32.794772520 +0800
@@ -1,5 +1,5 @@
#!/bin/bash
@@ -18,23 +16,20 @@ index 606c4f1..cab10be 100755
+/usr/share/clash/bypass-proxy-pid $$ 2>&1 > /dev/null
exec "$@"
-diff --git a/scripts/clash-default b/scripts/clash-default
-index eca38ad..82a78dc 100644
---- a/scripts/clash-default
-+++ b/scripts/clash-default
-@@ -10,6 +10,6 @@ NETFILTER_MARK=114514
+diff --color --unified --recursive --text a/scripts/clash-default b/scripts/clash-default
+--- a/scripts/clash-default 2022-02-27 11:13:08.792924323 +0800
++++ b/scripts/clash-default 2022-02-27 11:14:54.558733190 +0800
+@@ -10,5 +10,5 @@
IPROUTE2_TABLE_ID=114
# dns redirect
-FORWARD_DNS_REDIRECT=1.0.0.1:53
+FORWARD_DNS_REDIRECT=198.18.0.2:53
-
-diff --git a/scripts/clash.service b/scripts/clash.service
-index 552e56c..494069a 100644
---- a/scripts/clash.service
-+++ b/scripts/clash.service
-@@ -1,11 +1,11 @@
+diff --color --unified --recursive --text a/scripts/clash.service b/scripts/clash.service
+--- a/scripts/clash.service 2022-02-27 11:13:08.792924323 +0800
++++ b/scripts/clash.service 2022-02-27 11:15:53.700626313 +0800
+@@ -1,12 +1,12 @@
[Unit]
Description=A rule based proxy tunnel
-After=network-online.target nftables.service iptabels.service
@@ -42,7 +37,8 @@ index 552e56c..494069a 100644
[Service]
Type=simple
--ExecStartPre=+/usr/lib/clash/setup-cgroup.sh
+ LimitNOFILE=65535
+-ExecStartPre=/usr/lib/clash/setup-cgroup.sh
-ExecStart=/usr/bin/bypass-proxy /usr/bin/clash -d /srv/clash
+ExecStartPre=+/usr/share/clash/setup-cgroup.sh
+ExecStart=/usr/share/clash/bypass-proxy /usr/bin/clash -d /etc/clash
diff --git a/clash-premium-script.install b/clash-premium-script.install
index e070bc31197b..1d21cdd5d121 100644
--- a/clash-premium-script.install
+++ b/clash-premium-script.install
@@ -1,5 +1,4 @@
post_install() {
- systemctl daemon-reload
echo "+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++"
echo "+ Install successfully +"
echo "+ +"
@@ -14,14 +13,6 @@ post_install() {
}
post_upgrade() {
- systemctl daemon-reload
- systemctl restart clash
+ post_install
}
-pre_remove() {
- systemctl disable --now clash
-}
-
-post_remove() {
- systemctl daemon-reload
-}