summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormidnightix2021-09-07 22:43:53 +0800
committermidnightix2021-09-07 22:43:53 +0800
commit694338fe57ec247189901d8cdb0026f5f4e4ba60 (patch)
tree2e88634f67652eac48f3ac81b68aa77d756bb6e1
parente76a601e5087e7fa096c6630b5b9a3533d1c24d6 (diff)
downloadaur-694338fe57ec247189901d8cdb0026f5f4e4ba60.tar.gz
fix upstream binary url
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b637d199ec2c..7a4967e2e932 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,10 +17,10 @@ pkgbase = clash-premium-tun
conflicts = clash
backup = etc/clash/config.yaml
source = git+https://github.com/Kr328/clash-premium-installer.git#commit=e729951
- source = https://github.com/Dreamacro/clash/releases/download/premium/clash-linux-amd64-2021.07.03-49-gf09c567.gz
+ source = https://github.com/Dreamacro/clash/releases/download/premium/clash-linux-amd64-2021.09.07.gz
source = config.yaml
sha256sums = SKIP
- sha256sums = 0793978094543482b9ff90eb7e50453f946da4f52c0160591c0970dfc4b68bc8
+ sha256sums = 2ba573b8a5fe7f265e28b6a450d8af875f9cf84f2bf5d10c262a9af27a932de0
sha256sums = 1938bc7544f8e33a6e41636f45e87a17de2eac0ca14f47c2f7a71c3c87341bf0
pkgname = clash-premium-tun
diff --git a/PKGBUILD b/PKGBUILD
index 2c5930032567..cf6baafc0ce5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,10 +14,10 @@ provides=('clash')
conflicts=('clash')
backup=("etc/clash/config.yaml")
source=("git+https://github.com/Kr328/clash-premium-installer.git#commit=e729951"
- "https://github.com/Dreamacro/clash/releases/download/premium/clash-linux-amd64-2021.07.03-49-gf09c567.gz"
+ "https://github.com/Dreamacro/clash/releases/download/premium/clash-linux-amd64-${pkgver}.gz"
"config.yaml")
-sha256sums=('SKIP'
- '0793978094543482b9ff90eb7e50453f946da4f52c0160591c0970dfc4b68bc8'
+sha256sums=('SKIP'
+ '2ba573b8a5fe7f265e28b6a450d8af875f9cf84f2bf5d10c262a9af27a932de0'
'1938bc7544f8e33a6e41636f45e87a17de2eac0ca14f47c2f7a71c3c87341bf0')
prepare() {
@@ -34,8 +34,8 @@ prepare() {
package() {
cd "${srcdir}"
- gunzip --force clash-linux-amd64-2021.07.03-49-gf09c567.gz
- install -Dm 755 clash-linux-amd64-2021.07.03-49-gf09c567 "${pkgdir}"/usr/bin/clash
+ gunzip --force clash-linux-amd64-${pkgver}.gz
+ install -Dm 755 clash-linux-amd64-${pkgver} "${pkgdir}"/usr/bin/clash
install -Dm 644 config.yaml "${pkgdir}"/etc/clash/config.yaml
cd "${srcdir}"/clash-premium-installer/scripts
install -Dm 644 clash-default "${pkgdir}"/etc/default/clash