summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorh_cheung2020-04-29 12:35:53 +0800
committerh_cheung2020-04-29 12:35:53 +0800
commit4d2a3b14a55571291309d7be38201f602629527e (patch)
tree90708212ee24918ab896f4319c58cc43a7e6cb89
parent9b097e456bc52c919004f87e3f5f04d2eeaac80c (diff)
downloadaur-4d2a3b14a55571291309d7be38201f602629527e.tar.gz
update version, fix backup
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0a3c3e143cf..33f00fd44767 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clash-tun
pkgdesc = Clash Tun Scripts for Linux
- pkgver = 20200319.r402.2100ef7
- pkgrel = 2
+ pkgver = 20200426.r428.4d2ec55
+ pkgrel = 1
url = https://github.com/h0cheung/kr328-clash-setup-scripts
arch = any
license = custom
@@ -12,7 +12,7 @@ pkgbase = clash-tun
conflicts = clash-bin
conflicts = clash
conflicts = clash-dev-git
- backup = etc/clash/env
+ backup = etc/clash-tun/env
source = git+https://github.com/comzyh/clash#branch=add-water
source = git+https://github.com/h0cheung/kr328-clash-setup-scripts
source = https://raw.githubusercontent.com/comzyh/clash/master/LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index 5beaaab2d82b..e5e51ee95de1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: h_cheung <mail@h-cheung.cf>
pkgname=clash-tun
-pkgver=20200319.r402.2100ef7
-pkgrel=2
+pkgver=20200426.r428.4d2ec55
+pkgrel=1
pkgdesc="Clash Tun Scripts for Linux"
arch=('any')
url="https://github.com/h0cheung/kr328-clash-setup-scripts"
@@ -11,7 +11,7 @@ provides=("clash")
conflicts=("clash-bin" "clash" "clash-dev-git")
makedepends=('go' 'git')
depends=('glibc')
-backup=(etc/clash/env)
+backup=(etc/clash-tun/env)
options=()
source=("git+https://github.com/comzyh/clash#branch=add-water"
"git+https://github.com/h0cheung/kr328-clash-setup-scripts"
@@ -44,7 +44,9 @@ package() {
install -m 744 -D "setup-clash-tun.sh" "${pkgdir}/opt/script/setup-clash-tun.sh"
install -m 744 -D "setup-clash-cgroup.sh" "${pkgdir}/opt/script/setup-clash-cgroup.sh"
install -m 744 -D "clean-clash-tun.sh" "${pkgdir}/opt/script/clean-clash-tun.sh"
- install -m 644 -D "clash.service" "${pkgdir}/usr/lib/systemd/system/clash-tun.service"
+ install -m 644 -D "clash-tun.service" "${pkgdir}/usr/lib/systemd/system/clash-tun.service"
+ install -m 644 -D "clash-tun@.service" "${pkgdir}/usr/lib/systemd/system/clash-tun@.service"
+ install -m 644 -D "clash-cgroups.service" "${pkgdir}/usr/lib/systemd/system/clash-cgroups.service"
install -m 644 -D "env" "${pkgdir}/etc/clash-tun/env"
install -m 775 -d -o 65534 -g 1000 "${pkgdir}/srv/clash"
}