summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorh_cheung2020-03-21 19:36:23 +0800
committerh_cheung2020-03-21 19:36:23 +0800
commit9b097e456bc52c919004f87e3f5f04d2eeaac80c (patch)
tree035908c9348185e9bcd783f271ef9dcf8a15fdb8
parent7c669842ea19907a1041a3b6a8ae01eedabd5673 (diff)
downloadaur-9b097e456bc52c919004f87e3f5f04d2eeaac80c.tar.gz
update scripts
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6ff3082ef93..a0a3c3e143cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clash-tun
pkgdesc = Clash Tun Scripts for Linux
- pkgver = 20200201.r366.bbafb89
- pkgrel = 1
+ pkgver = 20200319.r402.2100ef7
+ pkgrel = 2
url = https://github.com/h0cheung/kr328-clash-setup-scripts
arch = any
license = custom
@@ -12,6 +12,7 @@ pkgbase = clash-tun
conflicts = clash-bin
conflicts = clash
conflicts = clash-dev-git
+ backup = etc/clash/env
source = git+https://github.com/comzyh/clash#branch=add-water
source = git+https://github.com/h0cheung/kr328-clash-setup-scripts
source = https://raw.githubusercontent.com/comzyh/clash/master/LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index 0c15c87df3e6..5beaaab2d82b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: h_cheung <mail@h-cheung.cf>
pkgname=clash-tun
-pkgver=20200201.r366.bbafb89
-pkgrel=1
+pkgver=20200319.r402.2100ef7
+pkgrel=2
pkgdesc="Clash Tun Scripts for Linux"
arch=('any')
url="https://github.com/h0cheung/kr328-clash-setup-scripts"
@@ -11,7 +11,7 @@ provides=("clash")
conflicts=("clash-bin" "clash" "clash-dev-git")
makedepends=('go' 'git')
depends=('glibc')
-backup=()
+backup=(etc/clash/env)
options=()
source=("git+https://github.com/comzyh/clash#branch=add-water"
"git+https://github.com/h0cheung/kr328-clash-setup-scripts"
@@ -45,5 +45,6 @@ package() {
install -m 744 -D "setup-clash-cgroup.sh" "${pkgdir}/opt/script/setup-clash-cgroup.sh"
install -m 744 -D "clean-clash-tun.sh" "${pkgdir}/opt/script/clean-clash-tun.sh"
install -m 644 -D "clash.service" "${pkgdir}/usr/lib/systemd/system/clash-tun.service"
+ install -m 644 -D "env" "${pkgdir}/etc/clash-tun/env"
install -m 775 -d -o 65534 -g 1000 "${pkgdir}/srv/clash"
}