summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Wozniak2016-02-06 16:30:14 +0100
committerPatrick Wozniak2016-02-06 16:30:14 +0100
commit1903e3353c9a0024dd7cf366874d1c4d35ce2677 (patch)
tree27693b6a40d058e74866082421e4a1cf35d3b108
downloadaur-1903e3353c9a0024dd7cf366874d1c4d35ce2677.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de106e35c605
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sat Feb 6 15:30:02 UTC 2016
+pkgbase = classifier-git
+ pkgdesc = Organize files in your directory instantly, by classifying them into different folders (git-version)
+ pkgver = 20160206.r74.d13d6c2
+ pkgrel = 1
+ url = https://github.com/bhrigu123/classifier
+ arch = any
+ license = MIT
+ depends = python
+ source = classifier::git+https://github.com/bhrigu123/classifier.git#branch=master
+ sha256sums = SKIP
+
+pkgname = classifier-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be09f5b8a94a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Patrick Wozniak <hello@patwoz.de>
+
+pkgname=classifier-git
+pkgver=20160206.r74.d13d6c2
+pkgrel=1
+pkgdesc="Organize files in your directory instantly, by classifying them into different folders (git-version)"
+
+arch=('any')
+url="https://github.com/bhrigu123/classifier"
+license=('MIT')
+
+depends=(
+ 'python'
+)
+optdepends=(
+)
+makedepends=(
+)
+conflicts=(
+)
+
+backup=(
+)
+
+source=(
+ "${pkgname%-git}::git+${url}.git#branch=master"
+)
+sha256sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "%s.r%s.%s" "$(date +%Y%m%d)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}