summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Ferreira Fontenelle2015-06-20 13:58:21 -0300
committerLeonardo Ferreira Fontenelle2015-06-20 13:58:21 -0300
commit1c00f6babf4dee74695e4120fe9350702a16dece (patch)
tree277f2189174b908e0a88d67ae9a6cce4663a8220
downloadaur-1c00f6babf4dee74695e4120fe9350702a16dece.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee2ad0bbe4cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = classix
+ pkgdesc = ICD-10 lookup application
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = http://code.google.com/p/classix/
+ arch = any
+ license = GPL
+ depends = python2>=2.5
+ depends = sqlite3
+ depends = pygtk>=2.10
+ depends = pygobject>=2.12
+ source = http://classix.googlecode.com/files/classix-0.3.1.tar.gz
+ md5sums = 0b372d7bd85d19e10a5c60af492adf64
+
+pkgname = classix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b4e25680ca0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Leonardo Ferreira Fontenelle <leonardof@gnome.org>
+pkgname=classix
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="ICD-10 lookup application"
+arch=('any')
+url="http://code.google.com/p/classix/"
+license=('GPL')
+#groups=()
+depends=('python2>=2.5' 'sqlite3' 'pygtk>=2.10' 'pygobject>=2.12')
+#makedepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+#install=
+source=("http://classix.googlecode.com/files/$pkgname-$pkgver.tar.gz")
+#noextract=()
+md5sums=('0b372d7bd85d19e10a5c60af492adf64') #generate with 'makepkg -g'
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ export PYTHON="$(which python2)"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/usr" install
+}
+