summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2022-10-24 09:13:43 +0200
committerChristian Hesse2022-10-24 09:13:43 +0200
commit5c4101c618f2873466f621d0fa1e8b5a792a0e8c (patch)
tree939b058faaa625df25ac3b35bea6c5d85cf61993
parentb4e640fa77ec6ab904be3e0777e3423755a7dd5e (diff)
downloadaur-claws-mail-git.tar.gz
commit claws-mail-git 4.1.1.r1.g1e3b95e1d-1
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD129
-rw-r--r--bash_completion30
3 files changed, 101 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fe0ebb7766f..17f905208d76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = claws-mail-git
pkgdesc = A GTK+ based e-mail client - git checkout
- pkgver = 3.17.4.r0.g215b6adc8
+ pkgver = 4.1.1.r1.g1e3b95e1d
pkgrel = 1
url = https://www.claws-mail.org/
arch = i686
@@ -9,18 +9,21 @@ pkgbase = claws-mail-git
makedepends = git
makedepends = spamassassin
makedepends = bogofilter
+ makedepends = networkmanager
makedepends = valgrind
makedepends = libgdata
makedepends = libnotify
makedepends = libcanberra
makedepends = poppler-glib
- makedepends = pygtk
+ makedepends = libytnef
+ makedepends = libical
makedepends = dillo
+ makedepends = python
makedepends = gumbo-parser
makedepends = docbook-utils
- makedepends = texlive-core
makedepends = texlive-formatsextra
- depends = gtk2
+ makedepends = lynx
+ depends = gtk3
depends = gnutls
depends = startup-notification
depends = enchant
@@ -29,9 +32,7 @@ pkgbase = claws-mail-git
depends = compface
depends = libsm
depends = dbus-glib
- depends = hicolor-icon-theme
- depends = desktop-file-utils
- optdepends = python2: needed for some tools and python plugin
+ optdepends = python: needed for some tools
optdepends = perl: needed for some tools and perl plugin
optdepends = spamassassin: adds support for spamfiltering
optdepends = bogofilter: adds support for spamfiltering
@@ -45,16 +46,16 @@ pkgbase = claws-mail-git
optdepends = libgdata: for gdata plugin
optdepends = poppler-glib: for pdf viewer plugin
optdepends = ghostscript: for pdf viewer plugin
- optdepends = gumbo-parser: for litehtml_viewer plugin
+ optdepends = libical: for vcalendar plugin
optdepends = dillo: for dillo html viewer plugin
+ optdepends = webkit2gtk: for fancy webkit html viewer plugin
+ optdepends = gumbo-parser: for litehtml plugin
provides = claws
provides = claws-mail
- conflicts = claws-mail-extra-plugins
conflicts = claws-mail
- replaces = sylpheed-claws
- replaces = claws-mail-extra-plugins
source = claws-mail::git://git.claws-mail.org/claws.git
+ source = bash_completion
sha256sums = SKIP
+ sha256sums = 3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb
pkgname = claws-mail-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 51a972455644..adc865aa0490 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,44 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=claws-mail-git
-pkgver=3.17.4.r0.g215b6adc8
+pkgver=4.1.1.r1.g1e3b95e1d
pkgrel=1
pkgdesc='A GTK+ based e-mail client - git checkout'
arch=('i686' 'x86_64')
license=('GPL3')
url='https://www.claws-mail.org/'
-depends=('gtk2' 'gnutls' 'startup-notification' 'enchant' 'gpgme' 'libetpan' 'compface'
- 'libsm' 'dbus-glib' 'hicolor-icon-theme' 'desktop-file-utils')
-makedepends=('git' 'spamassassin' 'bogofilter' 'valgrind'
- # dependencies for plugins
- 'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'pygtk' 'dillo' 'gumbo-parser'
- # deps to build the docs
- 'docbook-utils' 'texlive-core' 'texlive-formatsextra')
-optdepends=('python2: needed for some tools and python plugin'
- 'perl: needed for some tools and perl plugin'
- 'spamassassin: adds support for spamfiltering'
- 'bogofilter: adds support for spamfiltering'
- 'libnotify: for notification plugin'
- 'libcanberra: for notification plugin'
- 'dbus: for notification plugin'
- 'libxml2: for rssyl plugins'
- 'curl: for vcalendar, rssyl and spamreport plugins'
- 'libarchive: for archive plugin and various other plugins'
- 'libytnef: for tnef_parse plugin'
- 'libgdata: for gdata plugin'
- 'poppler-glib: for pdf viewer plugin'
- 'ghostscript: for pdf viewer plugin'
- 'gumbo-parser: for litehtml_viewer plugin'
- 'dillo: for dillo html viewer plugin')
-replaces=('sylpheed-claws' 'claws-mail-extra-plugins')
-conflicts=('claws-mail-extra-plugins' 'claws-mail')
+depends=('gtk3' 'gnutls' 'startup-notification' 'enchant' 'gpgme'
+ 'libetpan' 'compface' 'libsm' 'dbus-glib')
+makedepends=('git' 'spamassassin' 'bogofilter' 'networkmanager' 'valgrind'
+ # dependencies for plugins
+ 'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'libytnef' 'libical'
+ 'dillo' 'python' 'gumbo-parser'
+ # deps to build the docs
+ 'docbook-utils' 'texlive-formatsextra' 'lynx')
+optdepends=('python: needed for some tools'
+ 'perl: needed for some tools and perl plugin'
+ 'spamassassin: adds support for spamfiltering'
+ 'bogofilter: adds support for spamfiltering'
+ 'libnotify: for notification plugin'
+ 'libcanberra: for notification plugin'
+ 'dbus: for notification plugin'
+ 'libxml2: for rssyl plugins'
+ 'curl: for vcalendar, rssyl and spamreport plugins'
+ 'libarchive: for archive plugin and various other plugins'
+ 'libytnef: for tnef_parse plugin'
+ 'libgdata: for gdata plugin'
+ 'poppler-glib: for pdf viewer plugin'
+ 'ghostscript: for pdf viewer plugin'
+ 'libical: for vcalendar plugin'
+ 'dillo: for dillo html viewer plugin'
+ 'webkit2gtk: for fancy webkit html viewer plugin'
+ 'gumbo-parser: for litehtml plugin')
+conflicts=('claws-mail')
provides=('claws' 'claws-mail')
-source=('claws-mail::git://git.claws-mail.org/claws.git')
-sha256sums=('SKIP')
+source=('claws-mail::git://git.claws-mail.org/claws.git'
+ 'bash_completion')
+sha256sums=('SKIP'
+ '3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb')
pkgver() {
cd claws-mail/
@@ -52,59 +56,42 @@ pkgver() {
}
prepare() {
- cd claws-mail/
+ cd claws-mail/
- # fixes for python2
- sed -i 's@^#!.*python.*@#!/usr/bin/python2@' tools/*.py
- git update-index --assume-unchanged tools/*.py
+ # run autogen without options
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd claws-mail/
-
- # run autogen without options - it runs ./configure for us, but we need to fix python first
- NOCONFIGURE=1 ./autogen.sh
+ cd claws-mail/
- # fixes for python2
- export PYTHON="/usr/bin/python2"
- sed -i 's:python -c:python2 -c:g' configure
+ ./configure --prefix=/usr --disable-static \
+ --enable-enchant \
+ --enable-gnutls \
+ --enable-ldap \
+ --enable-crash-dialog \
+ --enable-pgpmime-plugin \
+ --enable-spamassassin-plugin \
+ --enable-bogofilter-plugin \
+ --enable-fancy-plugin \
+ --enable-manual
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
- # add --enable-alternate-addressbook to the options to use the
- # new/alternate address book
- # do not forget to add claws-contacts to the dependencies then
- ./configure \
- --prefix=/usr \
- --disable-jpilot \
- --disable-maintainer-mode \
- --disable-manual \
- --disable-static \
- --enable-bogofilter-plugin \
- --enable-crash-dialog \
- --enable-enchant \
- --enable-gnutls \
- --enable-ldap \
- --enable-litehtml_viewer-plugin \
- --enable-pgpmime-plugin \
- --enable-silent-rules \
- --enable-spamassassin-plugin
- #--help
- make
-
- # build extra tools
- cd tools/
- make
}
package() {
- cd claws-mail/
+ cd claws-mail/
+
+ make DESTDIR="${pkgdir}" install
- make DESTDIR="${pkgdir}" install
+ install -Dm 644 "$srcdir"/bash_completion "${pkgdir}"/usr/share/bash-completion/completions/claws-mail
- # install extra tools
- # all executables and .conf files ; only top directory
- cd tools
- for FILE in $(find -maxdepth 1 -type f -and -perm /111 -or -name '*.conf'); do
- install -D -m0755 ${FILE} "${pkgdir}"/usr/lib/claws-mail/tools/${FILE}
- done
+ # install extra tools
+ cd tools
+ install -m755 -d "${pkgdir}"/usr/lib/claws-mail/tools
+ for files in *.pl *.py *.sh *.conf tb2claws-mail update-po uudec uuooffice README; do
+ cp -arv $files "${pkgdir}"/usr/lib/claws-mail/tools/
+ done
}
diff --git a/bash_completion b/bash_completion
new file mode 100644
index 000000000000..dcbcc8920759
--- /dev/null
+++ b/bash_completion
@@ -0,0 +1,30 @@
+# claws-mail(1) completion
+_claws-mail()
+{
+ local cur prev words cword
+ _init_completion || return
+
+ case $prev in
+ --help|-h|--version|-v|--version-full|-V)
+ return
+ ;;
+ --alternate-config-dir)
+ COMPREPLY=( $( find . -maxdepth 2 -name clawsrc | sed 's,/clawsrc,,' ) )
+ return
+ ;;
+ --select|--status|--status-full)
+ _filedir -d
+ return
+ ;;
+ --compose-from-file|--attach)
+ _filedir
+ return
+ ;;
+ esac
+
+ if [[ $cur == -* ]]; then
+ COMPREPLY=( $( compgen -W '$( _parse_help "$1" )' -- "$cur" ) )
+ return
+ fi
+} &&
+complete -F _claws-mail claws-mail