summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Rustand2019-08-12 20:52:39 +0200
committerLars Rustand2019-08-12 20:56:52 +0200
commitc1302f7d53b1e4885bd91f21fcec7fdae9d4cd3b (patch)
treef0549e7dcece32ce00a04e249c80ab18be2d90de
downloadaur-c1302f7d53b1e4885bd91f21fcec7fdae9d4cd3b.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dfe5c8efe717
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = claymore-miner-bin
+ pkgdesc = Claymore's dual Ethereum GPU miner
+ pkgver = 14.7
+ pkgrel = 1
+ url = https://github.com/Claymore-Dual/Claymore-Dual-Miner/
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = glibc
+ source = claymore-miner-bin-14.7.zip::https://github.com/Claymore-Dual/Claymore-Dual-Miner/releases/download/14.7/Claymore.s.Dual.Ethereum.AMD+NVIDIA.GPU.Miner.v14.7.-.LINUX.zip
+ sha256sums = 13e48d0732ee21571d6c397d77926c36ae0ace5458ef1e4c383d6565cfcf1ba9
+
+pkgname = claymore-miner-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a94678630a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Lars Rustand <rustand dot lars at gmail dot com>
+
+pkgname=claymore-miner-bin
+pkgver=14.7
+pkgrel=1
+pkgdesc="Claymore's dual Ethereum GPU miner"
+url="https://github.com/Claymore-Dual/Claymore-Dual-Miner/"
+arch=("i686" "x86_64")
+license=("unknown")
+depends=("glibc")
+source=("${pkgname}-${pkgver}.zip::https://github.com/Claymore-Dual/Claymore-Dual-Miner/releases/download/${pkgver}/Claymore.s.Dual.Ethereum.AMD+NVIDIA.GPU.Miner.v${pkgver}.-.LINUX.zip")
+sha256sums=('13e48d0732ee21571d6c397d77926c36ae0ace5458ef1e4c383d6565cfcf1ba9')
+
+package() {
+ mkdir -p $pkgdir/usr/share
+ cp -r "$srcdir/Claymore's Dual Ethereum AMD+NVIDIA GPU Miner v${pkgver} - LINUX" $pkgdir/usr/share/${pkgname}
+
+ mkdir -p $pkgdir/usr/bin
+ ln -s /usr/share/${pkgname}/ethdcrminer64 $pkgdir/usr/bin/ethdcrminer64
+ chmod +x $pkgdir/usr/share/${pkgname}/ethdcrminer64
+}