summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTpaefawzen2024-01-23 11:52:11 +0900
committerTpaefawzen2024-01-23 11:52:11 +0900
commit629d96e690ba35ff22bd9a39cb7ef2c2b27913f3 (patch)
treecaaccc2a8785870ff65d0abb56b9749f14f3ee1c
downloadaur-629d96e690ba35ff22bd9a39cb7ef2c2b27913f3.tar.gz
Hi
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD101
2 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97f16d72e944
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = clc-intercal
+ pkgdesc = New INTERCAL compiler (bundle)
+ pkgver = 1.pre94.pre2.4
+ pkgrel = 1
+ url = https://uilebheist.srht.site/
+ arch = any
+ license = custom
+ depends = perl
+ optdepends = perl-net-interface: for INET package
+ optdepends = ncurses: UI-Curses
+ optdepends = perl-term-readline-gnu: UI-Line
+ optdepends = perl-gtk3: UI-X
+ source = https://uilebheist.srht.site/dist/CLC-INTERCAL-1.-94.-2.4/CLC-INTERCAL-1.-94.-2.4.tar.gz
+ sha256sums = 4cbfa1c084fb53f66908b457668bb9ba086d826212d41a663f646bb65b95d1e8
+
+pkgname = clc-intercal
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a37f8cf1bfd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,101 @@
+# Maintainer: Tpaefawzen <GitHub: Tpaefawzen>
+
+# This is an example of a PKGBUILD for splitting packages. Use this as a
+# start to creating your own, and remove these comments. For more information,
+# see 'man PKGBUILD'. NOTE: Please fill out the license field for your package!
+# If it is unknown, then please put 'unknown'.
+
+pkgname=("clc-intercal"
+# "clc-intercal-base"
+# "clc-intercal-docs"
+# "clc-intercal-icalc"
+# "clc-intercal-inet"
+# "clc-intercal-ui-curses"
+# "clc-intercal-ui-line"
+# "clc-intercal-ui-x"
+# "vim-intercal"
+ )
+pkgbase=clc-intercal
+_actual_pkgver=1.-94.-2.4
+pkgver="${_actual_pkgver//-/pre}"
+pkgrel=1
+epoch=
+pkgdesc="New INTERCAL compiler (bundle)"
+arch=(any)
+url="https://uilebheist.srht.site/"
+license=('custom')
+groups=()
+depends=(perl)
+makedepends=()
+checkdepends=()
+optdepends=(
+ # "c-intercal: C-INTERCAL syslib" <- checkdepends
+ "perl-net-interface: for INET package"
+ "ncurses: UI-Curses"
+ "perl-term-readline-gnu: UI-Line"
+ "perl-gtk3: UI-X")
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+_pkgname_with_version="CLC-INTERCAL-${_actual_pkgver}"
+_source_dirname="$_pkgname_with_version"
+_url_base="https://uilebheist.srht.site/dist/${_pkgname_with_version}/"
+source=("${_url_base}${_source_dirname}.tar.gz")
+sha256sums=(4cbfa1c084fb53f66908b457668bb9ba086d826212d41a663f646bb65b95d1e8)
+
+build() {
+ cd "$_source_dirname"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$_source_dirname"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make -k test # oh... not check
+}
+
+package() {
+ cd "$_source_dirname"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+
+ # = OBTW the "make all" on Docs is NOOP
+
+ # Example programs
+ (
+ cd CLC-INTERCAL-Docs/doc/examples/
+ install -Dm0644 -t "$pkgdir/usr/share/clc-intercal/examples/" *.*i
+ install -Dm0644 -t "$pkgdir/usr/share/clc-intercal/examples/quantum/" *.*i
+ )
+ case $? in (0) :;; (*) false; esac
+
+ # HTML docs
+ (
+ cd CLC-INTERCAL-Docs/blib/
+ for _dir in htmldoc htmlexamples; do
+ find "$_dir" -type f \! -name .exists -exec install -Dm0644 -t "$pkgdir/usr/share/doc/clc-intercal/$_dir" {} \;
+ done
+ )
+ case $? in (0) :;; (*) false; esac
+
+ # = Additionally Vim syntax file
+ (
+ cd bonus/vim
+ for _dir in ftdetect syntax; do
+ find "$_dir" -type f -exec install -Dm0644 -t "$pkgdir/usr/share/vim/vimfiles/$_dir" {} \;
+ done
+ )
+ case $? in (0) :;; (*) false; esac
+
+ # = Finally COPYING file
+ # OBTW every "$src/COPYING" and "$src/CLC-INTERCAL-*/COPYING" are identifical
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/clc-intercal/" COPYING
+}