summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilydjwg2015-11-09 20:41:03 +0800
committerlilydjwg2015-11-09 20:41:03 +0800
commit04feff97623055de6c25525786299215b16931e5 (patch)
treeb5401f4b652941ab0ad5985f7bb9c10c9eb3ec6d
downloadaur-04feff97623055de6c25525786299215b16931e5.tar.gz
new package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25737cb81c8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cld2-git
+ pkgdesc = Compact Language Detector 2
+ pkgver = 196
+ pkgrel = 1
+ url = https://github.com/CLD2Owners/cld2
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ provides = cld2
+ provides = cld2-hg
+ provides = cld2-svn
+ conflicts = cld2-hg
+ conflicts = cld2
+ conflicts = cld2-svn
+ replaces = cld2-hg
+ replaces = cld2-svn
+ source = git+https://github.com/CLD2Owners/cld2.git
+ md5sums = SKIP
+
+pkgname = cld2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..690d608a5b9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: lilydjwg <lilydjwg@gmail.com>
+
+_pkgname=cld2
+pkgname=${_pkgname}-git
+pkgver=196
+pkgrel=1
+pkgdesc='Compact Language Detector 2'
+arch=('x86_64')
+url='https://github.com/CLD2Owners/cld2'
+license=('Apache')
+provides=('cld2' 'cld2-hg' 'cld2-svn')
+replaces=('cld2-hg' 'cld2-svn')
+conflicts=('cld2-hg' 'cld2' 'cld2-svn')
+makedepends=('git')
+source=('git+https://github.com/CLD2Owners/cld2.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git log -1 --pretty='%cd' --date=short | tr -d '-'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ cd internal
+ sh ./compile_libs.sh
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 internal/libcld2.so "${pkgdir}/usr/lib/libcld2.so"
+ install -Dm755 internal/libcld2_full.so "${pkgdir}/usr/lib/libcld2_full.so"
+
+ for header in internal/*.h public/*.h; do
+ install -Dm644 "$header" "${pkgdir}/usr/include/cld2/$header"
+ done
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+