summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2015-06-08 17:59:36 -0400
committergraysky2015-06-08 17:59:36 -0400
commitf13757631a7de5ad3f2325e680c7ccda2d7c2a8a (patch)
tree35db5f6cd4d1eebe728ecf8bfd8f4a669d553c51
downloadaur-f13757631a7de5ad3f2325e680c7ccda2d7c2a8a.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--ccm.install16
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67e3ca9207f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = clean-chroot-manager
+ pkgdesc = Wrapper scripts for managing clean chroots (64-bit and 32-bit).
+ pkgver = 2.67
+ pkgrel = 1
+ url = https://github.com/graysky2/clean-chroot-manager
+ install = ccm.install
+ arch = any
+ license = MIT
+ depends = devtools
+ conflicts = clean_chroot_manager
+ replaces = clean_chroot_manager
+ source = http://repo-ck.com/source/clean-chroot-manager/clean-chroot-manager-2.67.tar.xz
+ sha256sums = 1ec32e2fa4cfe3ff94573ed65d041896a5c0362688d1c66a190113d4f67aff71
+
+pkgname = clean-chroot-manager
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..000c39d26ff5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+
+pkgname='clean-chroot-manager'
+pkgver=2.67
+pkgrel=1
+pkgdesc='Wrapper scripts for managing clean chroots (64-bit and 32-bit).'
+arch=('any')
+url='https://github.com/graysky2/clean-chroot-manager'
+license=('MIT')
+depends=('devtools')
+conflicts=('clean_chroot_manager')
+replaces=('clean_chroot_manager')
+source=("http://repo-ck.com/source/$pkgname/$pkgname-$pkgver.tar.xz")
+sha256sums=('1ec32e2fa4cfe3ff94573ed65d041896a5c0362688d1c66a190113d4f67aff71')
+install=ccm.install
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 MIT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/ccm.install b/ccm.install
new file mode 100644
index 000000000000..71e448cfb71c
--- /dev/null
+++ b/ccm.install
@@ -0,0 +1,16 @@
+## arg 1: the new package version
+## arg 2: the old package version
+
+post_upgrade() {
+ for test in 2.55-1 2.17-1 2.22-1; do
+ if [ "$(vercmp $2 $test)" -lt 1 ]; then
+ echo
+ echo '--> Please check ~/.config/clean-chroot-manager.conf against the'
+ echo '--> provided /usr/share/clean-chroot-manager/ccm.skel to ensure it is'
+ echo '--> updated as the script does not do this automatically.'
+ exit 0
+ else
+ /bin/true
+ fi
+ done
+}