summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavion2018-12-25 20:33:25 +1100
committerXavion2018-12-25 20:33:25 +1100
commitdd276cda2dbc51d003bc3ebb2a7888478208703e (patch)
tree96ff23e9b732404fe0f3c603ad90620f55ba4ba0
downloadaur-dd276cda2dbc51d003bc3ebb2a7888478208703e.tar.gz
Initial AUR v4 importation
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
-rw-r--r--opera-as-browser.patch31
-rw-r--r--plugin-location.patch11
4 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9b774b1c1dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = clean-home
+ pkgdesc = Cleans up user's home directory by analyzing '.' config files/directories against a collaboratively maintained database
+ pkgver = 0.8
+ pkgrel = 1
+ url = http://cleanhome.sourceforge.net/
+ arch = any
+ license = GPL2
+ depends = perl
+ depends = perl-libwww
+ optdepends = firefox: for BrowserCall plugin
+ optdepends = opera: for BrowserCall plugin
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/sourceforge/cleanhome/cleanHome-0.8.tar.gz
+ sha1sums = 58545185bc63b5b4aceb23e6a699b69bd0a50e24
+
+pkgname = clean-home
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52a4f67390da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+# Original Contributor: DonVla <donvla@users.sourceforge.net>
+
+pkgname=clean-home
+_dirname_=cleanHome
+pkgver=0.8
+pkgrel=1
+pkgdesc="Cleans up user's home directory by analyzing '.' config files/directories against a collaboratively maintained database"
+arch=("any")
+url="http://cleanhome.sourceforge.net/"
+license=("GPL2")
+depends=("perl" "perl-libwww")
+optdepends=("firefox: for BrowserCall plugin" "opera: for BrowserCall plugin")
+options=(!emptydirs)
+source=(http://downloads.sourceforge.net/sourceforge/cleanhome/${_dirname_}-${pkgver}.tar.gz)
+
+build() {
+ cd "${srcdir}"/${_dirname_}
+
+ # Patches
+ patch -Np0 < "${startdir}"/plugin-location.patch
+ # optional: uncomment if you want to use opera
+ # patch -Np0 < "${startdir}"/opera-as-browser.patch
+
+ # Removals
+ rm "CHPlugins/AptCacheInfo.pm" "CHPlugins/DiskUsage.pm" "CHPlugins/DpkgInstallState.pm"
+}
+
+package() {
+ cd "${srcdir}"/${_dirname_}
+
+ # Directories
+ install -d "${pkgdir}"/usr/{share/${_dirname_}/,bin/}
+
+ # Application
+ cp -r * "${pkgdir}"/usr/share/${_dirname_}/
+ #for file in CHPlugins/*; do
+ # install -m 0644 "$file" "${pkgdir}"/usr/share/${_dirname_}
+ #done
+
+ # Binaries
+ #install -D -m 0755 "cleanhome.pl" "${pkgdir}"/usr/bin/${pkgname}
+ ln -s /usr/share/${_dirname_}/cleanhome.pl "${pkgdir}"/usr/bin/${pkgname}
+}
+
+sha1sums=('58545185bc63b5b4aceb23e6a699b69bd0a50e24')
diff --git a/opera-as-browser.patch b/opera-as-browser.patch
new file mode 100644
index 000000000000..d04ba636ce7f
--- /dev/null
+++ b/opera-as-browser.patch
@@ -0,0 +1,31 @@
+--- CHPlugins/BrowserCall.pm.orig 2008-07-31 18:21:51.000000000 +0200
++++ CHPlugins/BrowserCall.pm 2008-08-11 12:55:07.000000000 +0200
+@@ -7,7 +7,7 @@
+
+ use constant {
+ PLUGINNAME => 'BrowserCall',
+- PLUGINDESCRIPTION => 'Google for the file/dir (starts firefox)',
++ PLUGINDESCRIPTION => 'Google for the file/dir (starts opera)',
+ PLUGINAUTHOR => 'Henning Mersch',
+ PLUGINAUHTORCONTACT => 'Webpage: http://www.henning-mersch.de',
+ PLUGINKEYPROPOSAL => 'b', #required to be an Action Plugin
+@@ -45,7 +45,7 @@
+ my $self = shift;
+ my $file = shift;
+ my $googlefile = basename($file);
+- return "Start firefox and google for '$googlefile'";
++ return "Start opera and google for '$googlefile'";
+ }
+
+ # process()
+@@ -56,8 +56,8 @@
+ my $self = shift;
+ my $file = shift;
+ my $googlefile = basename($file);
+- print "Starting Forefox ..";
+- system("firefox http://www.google.de/search?q=$googlefile&ie=UTF-8");
++ print "Starting Opera ..";
++ system("opera http://www.google.de/search?q=$googlefile&ie=UTF-8");
+ return 0;
+ }
+
diff --git a/plugin-location.patch b/plugin-location.patch
new file mode 100644
index 000000000000..36653da83372
--- /dev/null
+++ b/plugin-location.patch
@@ -0,0 +1,11 @@
+--- cleanhome.pl.orig 2008-08-31 06:58:06.000000000 +1000
++++ cleanhome.pl 2008-08-31 09:15:31.000000000 +1000
+@@ -12,7 +12,7 @@
+ use Data::Dumper;
+
+ my $chpath = $FindBin::RealBin;
+-my $chpluginpath = $chpath."/CHPlugins";
++my $chpluginpath = "/usr/share/cleanHome/CHPlugins";
+
+ #program version
+ my $VERSION="0.6";