summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2019-10-13 18:16:40 +0200
committerHans-Nikolai Viessmann2019-10-13 18:16:40 +0200
commitac84c3a09b74042ba0f257a798055f9be926a37a (patch)
treeec1ca3265ad3551e8307a7c5e2a5c8e16ea129e7
parent2a9dda0fdbd429f7afc426a505c9e1642f450ad5 (diff)
downloadaur-ac84c3a09b74042ba0f257a798055f9be926a37a.tar.gz
fix incorrect env settings
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--clean-lang.sh5
3 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d17e9b2b369..0bf3b6bd1800 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clean-lang-bin
- pkgdesc = Clean is a general purpose, pure and lazy functional programming language.
+ pkgdesc = Provides the general purpose, pure and lazy functional programming language Clean.
pkgver = 3.0
- pkgrel = 3
+ pkgrel = 4
url = https://clean.cs.ru.nl
arch = x86_64
license = custom
@@ -10,7 +10,9 @@ pkgbase = clean-lang-bin
conflicts = clean-lang
replaces = clean-lang
source = https://ftp.cs.ru.nl/Clean/Clean30/linux/clean3.0_64.tar.gz
+ source = clean-lang.sh
sha256sums = c71024cc6d27df357fed771a75f5d43e584369c3ee963bfd6d5cffe9af731ca8
+ sha256sums = 872a1bbe40b2b846e7aef38cee182df731bd2fca60bfb639d44fbb8ed21649d3
pkgname = clean-lang-bin
diff --git a/PKGBUILD b/PKGBUILD
index c1c93450151c..ac6e14bec9b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=clean-lang-bin
pkgver=3.0
-pkgrel=3
-pkgdesc="Clean is a general purpose, pure and lazy functional programming language."
+pkgrel=4
+pkgdesc="Provides the general purpose, pure and lazy functional programming language Clean."
arch=('x86_64')
url="https://clean.cs.ru.nl"
license=('custom')
@@ -11,8 +11,10 @@ depends=('glibc')
conflicts=('clean-lang')
provides=('clean-lang')
replaces=('clean-lang')
-source=("https://ftp.cs.ru.nl/Clean/Clean30/linux/clean${pkgver}_64.tar.gz")
-sha256sums=('c71024cc6d27df357fed771a75f5d43e584369c3ee963bfd6d5cffe9af731ca8')
+source=("https://ftp.cs.ru.nl/Clean/Clean30/linux/clean${pkgver}_64.tar.gz"
+ 'clean-lang.sh')
+sha256sums=('c71024cc6d27df357fed771a75f5d43e584369c3ee963bfd6d5cffe9af731ca8'
+ '872a1bbe40b2b846e7aef38cee182df731bd2fca60bfb639d44fbb8ed21649d3')
package() {
cd "${pkgname/-lang-bin/}"
@@ -27,12 +29,19 @@ package() {
# remove empty dir
rmdir "$pkgdir/usr/Temp"
+ rmdir "$pkgdir/usr/lib/Generics/Clean System Files"
+ rmdir "$pkgdir/usr/lib/MersenneTwister/Clean System Files"
+ rmdir "$pkgdir/usr/lib/Dynamics/Clean System Files"
+ rmdir "$pkgdir/usr/lib/StdLib/Clean System Files"
# add missing binaries
install -Dm755 "bin/cpm" "$pkgdir/usr/bin/cpm"
install -Dm755 "bin/patch_bin" "$pkgdir/usr/bin/patch_bin"
install -Dm755 "bin/BatchBuild" "$pkgdir/usr/bin/BatchBuild"
+ # add profile
+ install -Dm755 "$srcdir/clean-lang.sh" "$pkgdir/etc/profile.d/clean-lang.sh"
+
# install license
install -Dm644 CleanLicenseConditions.txt "$pkgdir/usr/share/licenses/${pkgname}/CleanLicenseConditions.txt"
}
diff --git a/clean-lang.sh b/clean-lang.sh
new file mode 100644
index 000000000000..a933cf42a824
--- /dev/null
+++ b/clean-lang.sh
@@ -0,0 +1,5 @@
+# These env variables are need to make Clean's compiler and
+# build system to work correctly.
+
+export CLEANLIB=/usr/lib/exe
+export CLEANPATH=/usr/lib/StdEnv